Layouts

images\icon_layout.gif Layouts are components that allow us to design printing jobs. When opened in a layout window, a layout allows us to drag and drop components such as drawings, images, maps, surfaces, tables, palettes and labels components into the layout. Charts, comments, queries and scripts can also appear in layouts. We can then resize or reposition those items to arrange the appearance of our printed page. Items in layouts may be copied and pasted within the layout. Layouts may be based upon layout templates to use standardized arrangements.

 

Layout windows are scaled so that the layout shown looks exactly like the printed page that will be created. Choosing View - Zoom To - 1:1 will zoom the layout to a 1:1 view that shows it on the monitor exactly as it will be printed. If we are working with US Letter sized paper in landscape orientation and we have a monitor that can show a display 11 inches by 8.5 inches, we will see a literal image of exactly how the printed page will appear.

 

Layouts will automatically be configured to show the printed page as it would look given current Page Setup settings for the printer selected. Layouts save their last-used printer settings when the project is saved. To change margins in the layout, use the Page Setup dialog. The Page Setup dialog uses inches or millimeters depending on the setting of the Use English Measurement Units checkbox in the Tools - Options dialog.

 

Layouts are not only used for printing, they may be used to create images of arbitrary DPI resolution using the Tools - Make Image command and are also used to save an image of the layout in graphics file formats such as .emf, .ps or .pdf.

 

Creating a Layout

 

Layouts may be created in two ways. The first way is to create a layout based on a particular component, such as a drawing, and to then add any other components to the layout. The second way is to create a blank layout and to then drag and drop components into the layout.

 

The first method will automatically scale the component that is used to create the layout to fill an entire page or, in the case of text components like tables or comments, the layout will be expanded to a multipage layout to allow the entire component to be printed. This component will automatically be the main component so that addition of any system generated text expressions will use this component. The first method is convenient when one main component will be the subject of the layout.

 

The second method may be more convenient when several components will be the subject of the layout, or when a layout is being created for use as a standard layout with many different projects.

 

To Create a Layout

 

1. Click on the project pane and create a new layout with File - Create - Layout. If the layout is to be based upon a particular component, choose that component in the Create Layout dialog.

2. In the Create Layout dialog, if a template is to be used check the Template box and choose a template. If the layout is to be blank, check the No parent box and no component will be loaded into the layout by default.

3. Open the new layout.

4. Verify paper size and other overall options are correctly specified in File - Page Setup .

5. Drag and drop components that are to appear from the project pane into the layout.

6. Insert any objects such as vertical or horizontal lines, text labels, etc.

7. Edit the component elements in the layout to change size, position, views to be printed, etc.

8. Use File - Print to print the layout.

 

Creating a layout based upon a non-text component, like a drawing, will automatically scale the component to fit the entire component on a single, full page. Creating a layout based upon a text component such as a table, query, script or comments component will automatically invoke the multipage layout capability to use as many pages as are necessary to show the entire component in the font size that is used.

 

Dragging and Dropping

 

We drag and drop items into a layout from the project pane. Begin by double clicking on the layout component to open it in a project pane. We can now click on an item in the project pane and drag and drop it into the layout window. Components that are dragged and dropped into a layout will at first appear as a fairly small layout element so they do not obscure other elements in the layout. Click on the component that's just been dropped to select it and then resize and reposition the element as desired.

 

Text Components in Layouts

 

Text components such as queries, scripts or comments are printed as text. Creating a layout based upon a comments, query or script component will adjust the number of pages vertically so the entire component is visible. Dragging and dropping a text component into a layout will create the usual small element that can be resized and repositioned as desired.

 

Text components (comments, queries and scripts) will always be printed with left alignment and will be word-wrapped to fit within the width of the layout element. Each tab will be replaced by four spaces. The default font used for the text component will be taken from the Tools - Options - Fonts page.

 

Selecting a text component in a layout for editing by CTRL-ALT clicking it will allow changing foreground color, background color and font using the format toolbar.

 

Inserting Items with the Tools Toolbar

 

The tools toolbar for layouts allows us to insert additional design elements into a layout. When a layout is the active window, the tools toolbar will change to show tools used with layouts.

 

images\tbar_tools_layouts.gif

 

Insert Horizontal Line

images\btn_layout_insert_horiz_line.gif

Create a horizontal line in the layout. Default line size is 1/20th of a point.

Insert Vertical Line

images\btn_layout_insert_vert_line.gif

Create a vertical line in the layout. Default line size is 1/20th of a point.

Insert Box

images\btn_shp_box.gif

Create a rectangular box with a click and a drag. Boxes have foreground and background color and line thickness that can be set by selecting the box and using the format toolbar. Default line size is 1/20th of a point.

Insert Box on Center

images\btn_shp_cbox.gif

Create a rectangular box centered on initial mouse click. Default line size is 1/20th of a point.

Insert Text

images\btn_layout_insert_label.gif

Add a text box, such as a caption, copyright notice or title, to the layout. Click on the text box to select it and then use the format toolbar to format the text. Double-click a text box in the layout to edit the text it contains.

Insert Legend

images\btn_insert_legend.gif

Add a legend to the layout, based upon a component used in the layout.

Insert North Arrow

images\btn_insert_north_arrow.gif

Add a North arrow to the layout, based upon a component used in the layout.

Insert Scale Bar

images\btn_insert_scale_bar.gif

Add a scale bar to the layout, based upon a component used in the layout.

 

When inserting horizontal or vertical lines, it is usually best to turn on the grid with View - Grid and to then use Snap to Grid to position layout element such as vertical and horizontal lines.

 

To add text, legends, North arrows and scale bars, click the tool and then click and drag open a horizontal box in the layout showing where the item is to appear. Inserting a legend, North arrow or scale bar will raise a dialog asking upon which component the item is to be based. If the layout does not contain any components for which a legend, North arrow or scale bar can be created, these buttons will be disabled.

 

The default line size of both horizontal and vertical lines is 1/20th of a point. Since this is a thinner line than can be displayed in one pixel on most monitors, keep in mind that the line will print more thinly than it appears on the monitor.

 

Creating Images from Layouts

 

Layouts have a special role in creating images because they capture and unify scale information for all of the elements that are used in them. This makes it possible to use layouts to create a single image at a specified resolution even though the layout is composed of drawings or other non-image elements.

 

To create an image from a layout, open the layout and use the Tools - Make Image command and specify the resolution desired (the default will be the resolution of the screen display, usually 72 or 96 DPI). This will create an image in the project. If an image file is desired, the image may then be exported to any image format supported by Manifold.

 

Another way of creating an image from a layout is to use File - Export - Image to save the layout as a .emf, .ps or .pdf file. When saving a layout via File - Export - Image we must specify the desired Pixel resolution and the Vector resolution of the file.

 

Pixel resolution (screen resolution by default) is used to save images and surfaces that are in the layout. Vector resolution (300 DPI by default) is used to save drawings and labels as well as layout elements such as text or horizontal and vertical lines. If saving to PDF for subsequent work in some other program before printing choose a Vector resolution setting that is the same as the resolution of the printer that will be used. If printing to a 600 DPI printer, for example, use 600 DPI. Pixel and Vector resolution must be at least 1 DPI and cannot exceed 7200 DPI.

 

See the How to Print topic for an example of saving a layout to a .pdf file.

 

Example

 

In this example we create a new layout from a drawing.

 

images\sc_layout_01.gif

 

We begin with a drawing of Mexico. We would like to print this drawing using a layout.

 

images\eg_howtoprint_02.gif

 

In the project pane toolbar we click on the Create button down arrow for a pull-down menu of project pane components that may be created.

 

images\eg_howtoprint_03.gif

 

We choose a Layout. This will pop open the Create Layout dialog.

 

images\eg_howtoprint_04.gif

 

The Create Layout dialog displays a list of all components in the project. This project only has one component, the Mexico drawing. We click on Mexico Drawing to highlight it and then press OK. If we wanted our new layout to be named something other than "Layout" we could have specified a new name as well. We will not use a template. See the Layout Templates topic for information on templates.

 

images\eg_howtoprint_05a.gif

 

In the project pane a new layout is created underneath the parent Mexico Drawing component. To open the layout, we double-click on it.

 

images\sc_layout_02.gif

 

The default layout will show the entire component on whatever is the default page size and orientation defined for our printer. Since most people use Letter or A4 sized paper in a portrait orientation it is quite likely the layout will look like that above. The light gray lines bordering the drawing show the extent of page margins that have been set for this printer.

 

Given the East - West extent of Mexico, our drawing would look better if printed on the paper in landscape orientation.

 

images\eg_howtoprint_06.gif

 

To change the paper orientation we choose File - Page Setup and click on Landscape, then we press OK.

 

images\sc_layout_03.gif

 

The layout will be redisplayed using landscape orientation for the paper. If we like, we can print the layout now with File - Print.

 

To continue this example we will resize and move the layout element that shows the Mexico drawing component. Before editing the layout we will first change the selection style used. Manifold can show selections in different styles, with the Dense Dots style being the default. It may be more convenient to show selections in layouts using the Border style.

 

images\eg_howtoprint_11.gif

 

To change the selection style we click on the down arrow of the Selection Style button in the selection toolbar.

 

images\eg_howtoprint_12.gif

 

We then choose Border.

 

We can now continue with the example.

 

images\sc_layout_04.gif

 

Layouts can contain more than one component. When a layout is created from a component as we have done above, it will contain that component as the initial design element in the layout. To select the layout element we CTRL-ALT click on it.

 

images\sc_layout_05.gif

 

The selected element will appear with a red border with editing handles. We can resize the element by clicking on an editing handle and dragging. Dragging on a corner will resize both the horizontal and vertical sides at the same time. We can also resize vertically and horizontally using the vertical and horizontal edit handles.

 

images\sc_layout_06.gif

 

The resize action will be shown with a moving preview box as we drag the mouse.

 

images\sc_layout_07.gif

 

Release the drag to finish the resize. The component seen in the layout will also be resized to fit in the maximum vertical or horizontal extent that it can fit.

 

images\sc_layout_08.gif

 

To move a selected element, click on it and drag.

 

images\sc_layout_09.gif

 

A preview box will appear as we drag the mouse to a new location.

 

images\sc_layout_10.gif

 

Releasing the drag will move the element to the new position.

 

images\sc_layout_11.gif

 

Clicking outside the selected element will deselect it.

 

Selection in Layouts

 

We normally use smart mouse selection within layouts, although of course the regular selection commands will work as well. Edit menu selection commands such as Select All, Select None and Select Inverse may be used. The Selections pane may be used to save selections. Selection styles may be altered. For example, many users will use the Border style within layouts.

 

To edit a layout element, use a CTRL-ALT click to select the element for editing. This will make the element the primary selected element.

 

Formatting operations (such as changing the font of a text element or the size of a line) will be applied to the primary selected element if there is more than element selected. For convenience, if only one element is selected the formatting toolbar will work for that element. This allows rapid clicking on an element to select it followed by formatting.

 

Rotating a Layout Element

 

Layout elements are shown “North Up” by default. An element may be rotated by selecting it for editing and then pressing the Element Rotation Angle button in the format toolbar.

 

images\eg_rotate_element_01.gif

 

Consider a layout element that’s been selected for editing.

 

images\btn_rotation_angle.gif We click the Element Rotation Angle button to rotate the element.

 

images\eg_rotate_element_02.gif

 

This calls up a menu of common choices for rotation angle. If we want to specify an angle not in the menu, we choose More for a dialog that allows us to specify an exact angle. We choose 40 to specify 40 degrees clockwise rotation.

 

images\eg_rotate_element_03.gif

 

The element is rotated 40 degrees clockwise. Note that the selection frame and editing handles also rotate. We can drag the editing handles in the new, rotated angular directions.

 

images\eg_rotate_element_04.gif

 

If we click outside the element to deselect it, we can see it has been rotated 40 degrees clockwise.

 

Properties for Drawings and Maps

 

How an element appears in a layout is controlled by its properties. Right click on the element and choose Properties in the context menu to call up a Properties dialog, or simply double click the element. Right click on a text element and choose Edit to edit the text.

 

The Properties dialog for a layout element showing a drawing has many properties:

 

images\dlg_layout_properties.gif

 

Scope

Choose Entire component, layer, locked rectangle, locked center / scale, saved selection, selection, or view to specify the contents of the element. If views or selections have been saved, choosing view or saved selection will enable the choice box to the right with all of the views or saved selections available.

Paging

Controls the printing of this component within multipage layouts:

continuous - Spread output evenly across the entire range of pages they appear on.

individual - Confine output to only that portion of a page on which the component appears and replicate this output likewise on all pages. Used to create overview maps with a printout repeating on all pages.

pages or page ranges

Used with multipage layouts to control which page this element appears in. Enter a series of page numbers or page ranges separated by commas. White space is ignored and reverse ranges are interpreted correctly. For example, We could enter 1, 2, 5-8 or 1, 2, 8-5 and get the same results. See the Multipage Layouts topic.

Background

Show the background color for this component, or change it in the layout. Choose auto, custom or none. custom allows choice of a custom background color in the adjacent color well.

Control points

Display any control points embedded in this component. Choose auto, hide or show.

Graticule

Display a graticule overlaying this component. Choose auto, hide or show. A graticule will not be displayed in the layout unless the user has explicitly configured it in the component's window using View - Graticule.

Grid

Display a grid overlaying this component. Choose auto, hide or show. A grid will not be displayed in the layout unless the user has explicitly configured it in the component's window using View - Grid.

Legend

Display the legend defined for this component. Choose auto, hide or show.

North arrow

Display the North arrow defined for this component. Choose auto, hide or show.

Scale bar

Display the scale bar defined for this component. Choose auto, hide or show.

Border

Show a border for this component. By default, no border is shown. Borders are drawn using the color shown in the adjacent color well, black by default. Choosing coordinates, coordinates (graticule) or coordinates (grid) for a border style will print labels along the edges of the border. The default font is set by the Border entry in the Tools - Options - Fonts dialog.

[color well]

Choose a color for the border.

Abc

Enabled when using a coordinates border style. Double-click to choose the font to be used for labels.

Size

Enabled when using a coordinates border style. Specify the width in points of the border margin in which coordinate labels are shown.

Interval

Enabled when using a coordinates border style. The stepping between label values and the unit of measure to be used.

Rounding

Enabled when using a coordinates border style. A formatting option that rounds values for the coordinate labels as specified. For example, rounding to 1 digit will round down to the nearest ten with values like 115 rounded to 110 and 95 rounded to 90. The main usage of this formatting option is to suppress unwanted trailing zeros in minutes and seconds when using degrees - minutes - seconds format. Setting the Inteval to a fractional value such as 1.5 will automatically adjust Rounding. Choosing arc minute or arc second as the unit in Deg-min-sec format will also change Rounding automatically so that the specified units will appear with full precision.

Deg-min-sec format

Enabled when using a coordinates border style. Toggle between decimal degrees and degrees, minutes and seconds format when degree coordinates are used. Currently enabled only when the layout component is in Latitude / Longitude form. The default is to use decimal degrees format.

Resolve Overlaps

Enabled when using a coordinates border style. Automatically clip labels when so many are specified that they would overlap.

Border each page

Enabled when using a border style, for use when working with continuous style paging in multipage layouts. When checked, draws a border for each individual page as would be used for map books. When not checked, draws a single continuous border as would be used when the multipage printout is intended to be tiled together into a single large print.

 

Accessory visual elements such as legends, North arrows or scale bars are defined within the component shown in the layout. The Properties dialog allows us to specify how (and if) these will appear in the layout.

 

auto

Show if the item is turned on in the component window, otherwise hide.

hide

Always hide the item.

show

Always show the item.

 

For example, we might not have a scale bar turned on in a drawing when we open it in a drawing window but we might want to have the scale bar turned on in a layout. In that case, we would choose show to show the scale bar in the layout whether or not it is turned on in the drawing window.

 

Labels on Borders

 

A common task is to place labels along the borders of a layout element that show the latitudes and longitudes of locations within the element.

 

images\sc_layout_graticule_labels.gif

 

This is a two-step process in Manifold: first a graticule is configured for the element within its own window and then the graticule is used to guide the creation of labels in the layout window. Graticules are used to guide the placement and values of border labels because graticules provide a simple, visual way of choosing reasonably even intervals at which to show latitudes and longitudes.

 

To create latitude / longitude labels on the border of a layout element:

 

1. Suppose layout element in question is a drawing. Open the drawing in its own window.

2. Use View - Graticule to turn on a graticule and to configure it as desired.

3. In the layout window, right click on the drawing and choose Properties.

4. In the Properties dialog, choose coordinates (graticule) for the Border style.

5. Check the deg-min-sec format box if degrees, minutes and seconds format is desired.

6. Press OK.

 

Labels will appear along the border of the element at intervals and values aligned to the graticule lines. The labels will appear when the coordinates (graticule) option is selected in the Border style box. The graticule lines themselves will appear or not appear depending on the setting of the Graticule option. It is possible, therefore, to show latitude / longitude labels on the border based on the graticule while choosing hide for the Graticule option and thus not showing any graticule lines.

 

Graticule and grid labels will not be displayed in a layout unless a graticule or grid has been explicitly configured within the component's window using the View - Graticule or View - Grid commands.

 

When using coordinates (graticule) the graticule labels will be placed along all four edges of the layout entry as needed whether they are latitudes or longitudes. Note that latitude labels might appear on either upper and lower edges or, if need be, on the left or right edge of the layout.

 

images\ill_layout_graticule_labels.gif

 

With some projections as shown in the illustration above meridian lines will cross an upper or lower border edge as well as a left or right edge. It is possible in such cases to have one label for a meridian at the top edge of a layout and another label for the same meridian at the right edge of the layout. Manifold will automatically place graticule labels correctly in such cases.

 

When overlap resolution is turned on, vertical edges give priority to latitudes and horizontal edges give priority to longitudes. The locations of graticule labels in layouts for projected components are accurate to approximately 1/300th of a page.

 

See the Graticule Labels in a Print Layout example topic for creation of graticule labels.

 

Border options

 

In the Properties dialog for a layout element such as a map, drawing, image, labels component or surface the following options are available for Border styles:

 

coordinates

Print border labels using the native coordinates of the component. Projected drawings, for example, using projections with meters as units of measure will have labels in meters. Lat/lon drawings will have labels in degrees.

coordinates (graticule)

Print border labels with position and values aligned to graticule lines. Requires configuring a graticule first for the component in the component's window using View - Graticule. The preferred way of creating latitude and longitude border labels.

coordinates (grid)

Print border labels with position and values aligned to grid lines. Requires configuring a grid first for the component in the component's window using View - Grid. The preferred way of creating border labels at even intervals using native coordinates in projected drawings.

none

Do not show a border.

thick

Show a rectangular border using a thick line.

thin

Show a rectangular border using a thin line.

 

See the Graticule Labels in a Print Layout example topic for use of the above options.

 

Properties for Text Elements

 

Some layout components will have a simpler Properties dialog. For example, a text element will have just a few options in its Properties dialog:

 

images\dlg_layout_properties_01.gif

 

Bound to

The component from which this text element takes its system-generated text expressions.

Page filter

Used with multipage layouts to control which page this element appears in. Enter a series of page numbers or page ranges separated by commas. White space is ignored and reverse ranges are interpreted correctly. For example, We could enter 1, 2, 5-8 or 1, 2, 8-5 and get the same results. See the Multipage Layouts topic.

Border

Show a border for this component. By default, no border is shown. Borders are drawn using the color shown in the adjacent color well, black by default.

 

When a new text element is inserted into a layout that contains only one component element, the text element will automatically be bound to that component. If there are several components already in the layout the text element will be bound to none.

 

Views in Layouts

 

When the scope of a layout element is set to View, the layout element will use the view to guide what is displayed within the layout element. A view specifies a central point and a scale, but views themselves are limitless in extent. How much of the view is seen depends on the size of the layout element. If the element is resized smaller, less of the view will be seen. If the element is resized larger, more of the view will be seen.

 

Tables in Layouts

 

Layouts may be created from tables, and tables may also be dragged and dropped into a layout. See the Printing Tables topic for a discussion of tables and layouts.

 

Layouts with multiple elements

 

More than one component can be dragged and dropped into a layout.

 

images\eg_layout_01.gif

 

Suppose we've created a layout using a drawing of Europe. We CTRL-ALT click on the Europe element in the layout to select it for editing.

 

images\eg_layout_02.gif

 

We can now resize it by dragging the edit handles in the corners and the sides. For example, we could resize it by dragging on the lower right corner's edit handle to make the element smaller.

 

images\eg_layout_03.gif

 

For example, we could resize it so that it fits into the upper left corner of the page. Click anywhere else in the layout to deselect the drawing.

 

To add another component we drag and drop the component from the project pane into the layout. For example, suppose we have the sample Bronze image in our project. We can click on it and drag it from the project pane into the layout.

 

images\eg_layout_04.gif

 

When dragging into the layout the Bronze image will be dropped where we release the drag.

 

images\eg_layout_05.gif

 

The image appears in the layout where we drop it. It appears using a default size. We CTRL-ALT click on the image to select it for editing.

 

images\eg_layout_06.gif

 

We can now resize the image by dragging the upper left corner edit handle.

 

images\eg_layout_07.gif

 

We can then click and drag the image to move it to the upper right corner of the layout.

 

images\eg_layout_08a.gif

 

Click on any empty space to deselect the image.

 

images\eg_layout_08.gif

 

Suppose our project also contains the Schloss sample image. We can add it to the layout by dragging and dropping it from the project pane into the layout.

 

images\eg_layout_09.gif

 

As before, the element is dropped into the layout at the point we release the mouse button on the drag. The new image appears in a default size. We will CTRL-ALT click on the Schloss image to select it for editing.

 

images\eg_layout_10.gif

 

We can now resize the image by dragging any of the edit handles.

 

images\eg_layout_11.gif

 

After resizing, we can move this image by dragging it to a new location.

 

images\eg_layout_12.gif

 

In the illustration above, we've moved the Schloss image so that it partially overlaps the Bronze image in the layout.

 

If desired, we can move the Schloss image below the Bronze image so that the Bronze image is not partially covered up. To do so, we right click on the Schloss image and from the context menu choose Order - Move to Bottom.

 

images\eg_layout_13.gif

 

This will move the Schloss image to the bottom of the layout element stack so that it no longer covers up part of the Bronze image.

 

Aligning Items in Layouts

 

Items may be aligned in layouts by selecting them and then using the alignment toolbar to invoke commands that align those items. The alignment toolbar is turned off by default. To turn it on, open a layout, choose Tools - Customize and check the box for the alignment toolbar. Alignment toolbar commands allow us to line up items in the layout with each other, to resize them, to center them and otherwise place and size them as desired.

 

images\sc_print_layout_align_01.gif

 

Suppose we have a print layout with two elements, a drawing and an image. We clicked on the drawing to select it and then SHIFT-clicked the image to also select it as the primary selected item.

 

images\sc_print_layout_align_01a.gif

 

Clicking Align Bottom in the alignment toolbar will align the drawing to the bottom of the image. The alignment controls work by aligning all other selected items to the primary selected item (the one with the edit handles). See Smart Mouse Selection for quick moves to designate an item the primary selected item. See the Align Items in Layouts example topic.

 

images\sc_print_layout_align_02.gif

 

Commands from the alignment toolbar are repeated in the Layout menu Align, Center, Space, Resize Full and Resize Same commands. The Layout menu appears when a layout window has the focus.

 

Repositioning Multiple Items in Layouts

 

Clicking and dragging the primary selected item in a layout will move that item. SHIFT clicking and dragging the primary selected item in a layout will move that item and will also move all other selected items as well.

 

Creating Frames and Borders with Lines

 

Use the horizontal line and vertical line tools to create borders and frames to visually organize other elements in the layout.

 

Insert Horizontal Line

images\btn_layout_insert_horiz_line.gif

Create a horizontal line in the layout. The default line size is 1/20th of a point.

Insert Vertical Line

images\btn_layout_insert_vert_line.gif

Create a vertical line in the layout. The default line size is 1/20th of a point.

Insert Box

images\btn_shp_box.gif

Create a rectangular box with a click and a drag. Boxes have foreground and background color and line thickness that can be set by selecting the box and using the format toolbar. The default line thickness is 1/20th of a point.

Insert Box on Center

images\btn_shp_cbox.gif

Create a rectangular box centered on initial mouse click.

 

To assure lines start and stop at exactly desired locations, use a grid and Snap to Grid.

 

images\sc_layout_grid_01.gif

 

Choose View - Grid to launch the Grid dialog. Check the Show grid box to turn on the grid. Grids are created on a 1-centimeter spacing for layouts by default. Choose the X (horizontal) and Y (vertical) spacing and units desired and press OK.

 

images\sc_layout_grid_02.gif

 

The result is that a grid of dots appears within the layout.

 

images\btn_snap_to_grid_off.gif images\btn_snap_to_grid_on.gif

 

Turn on Snap to Grid by first showing a grid with the View - Grid command and then pushing the Snap to Grid button or by choosing Edit - Snap to - Grid from the main menu. When Snap to Grid is on, the mouse cursor will move only between grid points on the form. Lines may therefore be created with end points that are snapped exactly to locations marked by grid points. See the Edit - Snap To topic for additional details and extra commands.

 

images\sc_layout_grid_03.gif

 

We can then use Insert Vertical Line and Insert Horizontal Line to draw lines for borders and other boxes.

 

images\sc_layout_grid_04.gif

 

Seen without the grid turned on, this is a typical artistic arrangement for printing, where the subject of the map is in the upper area and the three bordered boxes along the lower edge might be filled, for example, with a logo, the title of the map and some additional information.

 

images\sc_layout_grid_05.gif

 

Seen zoomed in, we've added a map component and have added a text element with two lines in it.

 

images\btn_snapto_elements.gif The Snap To Elements button causes the cursor to snap to the corners of existing elements in the layout. This is a convenient way of aligning or resizing elements to match exactly the dimensions or edges of other elements.

 

Transparent Colors

 

Layout elements use transparent color by default for a background color, thus giving a "floating" effect so that whatever items are in the background can be seen through the element's "white space." Transparent background color is often used with text labels in layouts. Exceptions are vertical and horizontal lines, which do not have a background color and which do not allow transparent foreground color.

 

The Layers Pane and Layouts

 

When a print layout window has the focus the Layers pane will show each item in the layout as a layer. Available commands include:

 

·      Checking a box will turn the layout element on and unchecking the box will turn the layout element off. Hiding an element by unchecking its box will prevent it from being clicked, selected or printed.

·      Moving "layers" up and down in the layers pane will move the layout elements up and down relative to each other within the layout.

·      Double clicking onto a text label in the layers pane will allow immediate editing of the text in the box directly from the layers pane.

·      images\btn_delete_thing.gif The Delete Layer button in the layers pane toolbar will be enabled when any layer except the main layer is clicked. Deleting a layer will remove this element from the layout.

·      images\btn_properties.gif The Properties button in the layers pane toolbar will open the properties dialog for any component-based element in the layout.

 

The layers pane is a key control when working with complex layouts.

 

images\sc_layouts_layers_pane.gif

 

In the example above we see a layout together with the layers pane. The layout is based on a main element that is a drawing of Europe. Below it is a text element that consist of the phrase "Copyright 2002" repeated several times in an outline font using a light gray color. Above the main element is another text element giving the title, "Europe," and two images, the example Bronze and Schloss images. The Background layer is turned off, so behind the layout page we see the checkerboard pattern used in Manifold when there is no background.

 

Note that the layout elements added with layout tools, such as text, are shown in the layers pane with special "layout element" icons. Text elements will be named using the initial characters of their text. Components will be shown with their scope, so that if a component is used more than once with different scope (for example, with different views) it is easy to tell which element is which in the layers pane.

 

With many overlapping elements in a layout we can use the layers pane to turn off upper elements if we want to select or otherwise work with lower elements.

 

Layouts in the Layers Pane with other Components

 

When a drawing or map or other component from which a layout has been created has the focus the layers pane will show layouts as "layers" in the layers pane. Checking the box for one of these print layout layers will cause a layout rectangle to appear in the component that shows the region covered by the layout.

 

images\sc_dwg_layout_layers.gif

 

In the illustration above the drawing has four layouts that show different parts of Mexico. Three of the layouts have been checked in the layers pane causing three layout preview rectangles to appear in the drawing.

 

The preview layout rectangles will be automatically adjusted if we change the scope of the layout.

 

images\sc_dwg_layout_layers_01.gif

 

For example, suppose we open a drawing window and a layout window for the same drawing and show the layout in the drawing window by checking the layout layer's checkbox. We select an area in the drawing by clicking on it with Select Touch. The scope of the layout (set by right clicking the layout in the layout window and choosing Properties is set to entire component.

 

images\sc_dwg_layout_layers_02.gif

 

If we now change the scope of the layout to be the selection, the layout will show only the selected objects (one area, Germany, in this illustration) and simultaneously the drawing window will be updated to show the new region covered by this area.

 

Right clicking onto the hatched border of one of the layout rectangles in the drawing will cause a context menu to appear with controls based on that layout rectangle. For example, we can Zoom to a given layout rectangle, Print it or change its Properties. If a layout is empty (for example, if the layout scope is set to selection and nothing is selected in the parent component) zooming to the layout will do nothing.

 

Use Tools - Options - Colors - Layout Rectangle to change the color in which layout rectangles are shown. The default color is black.

 

Text

 

images\btn_insert_label.gif We can insert text into the layout using the Insert Text button. Click on the Insert Text button and then draw a text box in which the text will be located. In the Insert Text dialog, enter the text that is desired. See the How to Print topic for a detailed example of adding text to a layout.

 

After creating a text element in a layout we can later edit the text by double clicking on the text element.

 

System Generated Expressions for Text

 

The Insert Text dialog includes an upper pane that lists a hierarchy of available expressions that may be used to automatically insert system-generated text into a text element. Double-click onto an expression to add it to the text element. Values for the text element, like scale, are taken from the main element in the layout.

 

The Trim numbers option will automatically trim numbers generated by the system to the specified number of decimal digits. This is very useful when creating latitudes, longitude or other numbers and many digits to the right of the decimal point are not desired.

 

Let's consider an example. We will work with a project that has been saved in a file called Eurasia.map. We would like to add the name of the file to a layout.

 

images\dlg_layout_text_escape_01.gif

 

To do so we add a text element to the layout. We then click into the Insert Text dialog's lower pane and enter "Hello, my name is ". In the upper pane we can click on the Project folder to expand it for a list of available expressions related to the project.

 

images\dlg_layout_text_escape_02.gif

 

If we double-click onto the [Filename] expression it will be added to the text being assembled in the lower box. We can then click into the lower pane and add a period "." to finish the sentence.

 

images\dlg_layout_text_escape_03.gif

 

After we click OK we can see how the text appears in the layout. Note that [Filename] has been replaced with Eurasia.map, the name of the file.

 

The following expressions may be inserted into text elements. They will be replaced automatically with the corresponding text whenever the layout is refreshed. The values are taken from the parent component of the text element. To change the parent component of a text element, right click on the text element, choose Properties and then choose the component desired in the Bound to box.

 

Note: The names of the system-generated expressions are case sensitive. For example, [date] does will not work as a substitute for [Date].

 

Component

 

[Average Height]

Available for text elements bound to Profiles and Elevations elements in the layout. Gives the average height over the surface for the profile line. Profiles and elevations are optional components that are available when the Surface Tools package is installed. See the Profiles and Elevations topic for more information.

[Component]

The name of the parent component in the project.

[Coordinate System]

The coordinate system in use for the parent component (same as [Projection]).

[Datum]

Name of the datum in use in this projection / coordinate system.

[Description]

The contents of the parent component's Description property.

[Extent English]

Scale reported as horizontal extent in English units.

[Extent Metric]

Scale reported as horizontal extent in metric units.

[Maximum Height]

Available for text elements bound to Profiles and Elevations elements in the layout. Gives the maximum height over the surface for the profile line.

[Minimum Height]

Available for text elements bound to Profiles and Elevations elements in the layout. Gives the minimum height over the surface for the profile line.

[Page Center]

Center of the page in projected coordinates.

[Page Center LatLon]

Center of the page in latitude, longitude coordinates.

[Page Center LatLon DMS]

Center of the page in latitude, longitude coordinates using degrees, minutes and seconds notation.

[Page Center Latitude]

Latitude coordinate of the center of page in latitude, longitude coordinates.

[Page Center Latitude DMS]

Latitude coordinate of the center of page in latitude, longitude coordinates using degrees, minutes and seconds notation.

[Page Center Longitude]

Longitude coordinate of the center of page in latitude, longitude coordinates.

[Page Center Longitude DMS]

Longitude coordinate of the center of page in latitude, longitude coordinates using degrees, minutes and seconds notation.

[Page Center X]

X coordinate of the center of page in native units.

[Page Center Y]

Y coordinate of the center of page in native units of the component being printed.

[Projection]

The projection in use for the parent component.

[Scale]

Printing scale in absolute scale style, for example 1:10000.

[Scale English]

Scale in English units using relative scale style, as in 1 ft : 100.00 miles.

[Scale Metric]

Scale in Metric units using relative scale as in 1 cm : 100.00 km.

[Scale Numeric]

Scale as a 1:N ratio, same as [Scale].

[Unit]

Native unit used in coordinate system / projection.

Date and Time

 

[Date]

Current date in short date format specified in Windows Regional Options setting. A typical Windows default is "8/27/2003".

[Day]

Current day in the month from 1 to 31.

[Hour]

Current hour from 1 to 24.

[Long Date]

Current date in long date format specified in Windows Regional Options setting. A typical Windows default is "Wednesday, August 27, 2003" format.

[Minute]

Current minute, from 1 to 60.

[Month]

Current month, from 1 to 12.

[Month Abb]

Month as a three-letter abbreviation, such as "Aug".

[Month Name]

Month name, such as "August".

[Second]

Current second, from 1 to 60.

[Time]

Current time in format specified in Windows Regional Options setting. A typical Windows default is "3:41:08 PM".

[Weekday Abb]

Day as a three-letter abbreviation, such as "Wed".

[Weekday Name]

Day name, such as "Wednesday".

[Year]

Current year.

Layout

 

[Layout]

Report the name of the layout.

[Layout Description]

Report the description of the layout.

Print Job

 

[Computer]

Windows name of the computer executing the print job.

[Page]

Page number as printed.

[Page Above]

In multipage layouts, the page number of the page above this page. If no page exists above this page, prints "none".

[Page Below]

In multipage layouts, the page number of the page below this page. If no page exists below this page, prints "none".

[Page Left]

In multipage layouts, the page number of the page to the left of this page. If no page exists to the left of this page, prints "none".

[Page Right]

In multipage layouts, the page number of the page to the right of this page. If no page exists to the right of this page, prints "none".

[Pages]

Total number of pages in the print job.

[Page X]

When printing multipage layouts that are to be tiled together, the position from left to right of this page.

[Page Y]

When printing multipage layouts that are to be tiled together, the position from top to bottom of this page.

[Printer]

Windows name of the printer.

[Printer Port]

Windows name of the printer port.

[User]

User login running Manifold.

Project

 

[Filename]

Name + extension of the project file. In a new project, will be empty until the project is first saved.

[File Path]

Fully qualified name of the project file. In a new project, will be empty until the project is first saved.

[File Title]

Title of the project (displayed in the main window title). Before a project is saved for the first time will be something like "Project1". After the project is saved, will be the same as the project file name without the .map extension.

 

Square brackets [ ] may be used in running text within text elements as long as the square brackets are not used exactly in one of the above escape sequences (in which case the escape sequence will be replaced by the information it contains. Therefore, one can create a text element in a Manifold layout such as

 

Figures shown as [123] values are elevations.

 

If we don't like the default [Date], [Long Date] and [Time] formats used by Windows we may easily change them using the Control Panel's Regional Options applet. For example, we can change from AM/PM designations to 24-hour time, remove the day of the week from the [Long Date] and so on.

 

Scale text is reported in either relative scale or horizontal extent styles similar to those available for use in the status bar scale report. Relative scale reports the ratio between one centimeter or inch and the scaled number of meters/kilometers or feet/miles as in, for example, 1 cm : 100.00 km. Horizontal extent shows the horizontal size of the main layout entry.

 

Note that in the hierarchical list of system-generated expressions, the component folder will only be available for text entries belonging to layouts that were created from a component in the first place; otherwise, it would be unclear what component is being referred to.

 

Multipage Printing

 

A layout can be expanded to use more than one page with Layout - Pages and specifying the number of pages in the horizontal (x) and vertical (y) directions. Elements in the layout cannot be resized across page boundaries, although a single element can cover the entire multipage layout.

 

Using Maps or Using Layouts

 

For sophisticated compositions there may be a choice as to whether to create the visual effect desired in the layout by first composing multiple layers in a map and then using that map in a layout, or composing multiple elements in a layout. We might use a combination of both approaches.

 

For example, one can create a title block either in a layout or in a map. Suppose we want to create a rectangular box that contains a main title. We could create this in a layout by inserting a box using the controls in the Tools toolbar and then using the Insert Label command from the toolbar to add a text element.

 

We could also achieve the same result by creating a map that had three layers consisting of two drawings and a labels component. For example, suppose we wished to print a map that included a title caption with the text "Europe" in a box.

 

images\sc_layouts_caption_01.gif

 

We could create a map that provided this caption.

 

images\sc_layouts_caption_02.gif

 

The map could consist of three layers as seen above. The bottom layer is simply a rectangular area colored white. If we drag and drop this map into a layout, the white rectangle will provide a blank white background for the title text no matter what is underneath in the layout.

 

This same caption could have been created using the print layout Insert tools described at the beginning of this topic. For simple captions we would no doubt create the title block using the layout. For more elaborate effects, such as the use of Gaussian drop shadows, we would use the map.

 

Printing to Scale

 

Printing to scale is accomplished by first creating a view at the desired scale and then printing that view within a layout.

 

To print at a given scale:

 

1. Open the map you want to print. Make sure it is a projected map.

2. Use View - Zoom To for setting the desired scale, for example 1:3000000.

3. In the Views pane, create a new view. Rename the view to a memorable name such as "New York 1: 3000000".

4. Create a layout component. Open the layout window and drag and drop the map component from the project pane into the layout window.

5. Right-click the map image within the layout window and select Properties. Set Scope to View and select the view created in step 3. Press OK.

 

When printing to scale, make sure the view selected is centered upon the area of interest. The actual extent of the component visible in the layout element will be controlled by the scale and by the size of that layout element on the page.

 

Status Bar and Scale in Layouts

 

The status bar for layouts will report mouse cursor position in either inches or millimeters depending on the value of the Use English measurement units option in Tools - Options - User Interface. Page numbers will be added if a multipage layout is used.

 

The scale readout in the status bar gives the scale of the layout (in actual paper size) relative to the screen display. If the scale readout is set to use absolute scale (as in "1:100") and the layout is zoomed using View - Zoom to into a zoom of 1:1, then the layout will appear on the monitor in exactly the size that it will be printed. The status bar readout will also be 1:1.

 

For example, suppose we have a layout that uses one sheet of Letter size (8.5 x 11 inches) paper in Landscape mode and we have a very large, high-resolution monitor. We can zoom in to 1:1 scale in the layout and it will appear as an 8.5 inch by 11-inch sheet on the monitor.

 

Note that the scale reported in the status bar is not the geographic scale of what is in the layout but rather the scale of the layout as it would be printed on real paper compared to what is shown in the monitor. To get the geographic scale of the component as it will be when printed, insert a text element and use one of the system generated text expressions, such as [Scale] to report a scale in the text.

 

Using Layouts Templates for Repetitive Work

 

If we create many print jobs we may want to use the same type of layout for more than one job, repeating standard border arrangements. The best way to accomplish this goal is to use layout templates. Layout templates are by far the fastest and easiest way of recycling the look and feel of layouts into other layouts. If you create a lot of similar layouts, it is wise to master the use of layout templates. See the Layout Templates topic for details.

 

Copy and Paste

 

If desired, we can use Copy and Paste to move layouts between different instances of Manifold. Launch Manifold and open the project in which a layout is saved. Launch a second instance of Manifold in which the working project will be done. Copy the layout from the first instance of Manifold and paste it into the second instance of Manifold.

 

When copying and pasting layouts between different instances of Manifold all layout elements for components along with all dependent legends, North arrows, scale bars and text elements bound to a specific component will be removed. Nonetheless, the copy and paste method is very useful for many types of simple layouts consisting of boxes and vertical and horizontal lines and generic text such as copyright notices, statements of legal policy and so forth.

 

Using Copy and Paste to make copies of layouts within the same project is a good way to avoid irreversible errors when altering complex layouts. When a layout gets to the point that an error would be inconvenient to reverse, make a copy of the layout and continue working with the copy.

 

Layouts and Enterprise Edition

 

When using Enterprise Edition layouts can be shared to an Enterprise server. The Share command is enabled even if the main component in the layout is not shared. However, when sharing a layout, the system will automatically share all components used by that layout to the same Enterprise server if they are not yet shared. Note that it is possible to have an unshared layout that includes a shared component but it is not possible to have a shared layout that includes an unshared component.

 

Notes

 

Layouts may be copied and pasted, and layouts may be imported from a different project by using File - Import - Component.

 

The example date used for the system generated date, Wednesday, August 27, 2003, marked the closest approach between Earth and Mars in approximately 73,000 years.

 

When used with layouts, the tracker tool will report in either English (inches) or metric units depending on the setting of the Use English measurement units option in Tools - Options.

 

Tech Tip: Printing a Layout to PDF

 

There are two ways to create a PDF file from a layout: exporting a layout to a PDF or "printing" the layout using a PDF virtual printer driver, which mimics a printer to capture any printing activity as a PDF.

 

Printing a layout to a virtual printer driver that produces PDF feeds the layout through an ordinary GDI / GDI+ rendering pipeline, which issues "dumb" printing commands that are then captured by the driver. Exporting a layout directly as a PDF feeds the layout through the Manifold PDF rendering engine, which optimizes printing commands. In general, the results of exporting a layout as a PDF will almost always be better than the results of printing the same layout to a virtual printer driver.

 

See Also

 

Exporting Layouts

View - Zoom

View - Graticule

View - Grid

View - Legend

View - North Arrow

View - Scale Bar

Graticule Labels in a Print Layout

Align Items in Layouts