georeference.org
Subscribe to this thread
Home - General / All posts - Radian installation
firsttube


1,424 post(s)
#01-Mar-17 14:59

I had installed the first release of Radian with no issue. Now I'm trying to update it to the newest build and when I run the msi installer file I get the message box as attached. It's looking for the old msi file? Not sure what to do here...

Attachments:
radian.JPG


"The blessing in life is finding the torture you are comfortable with." - Jerry Seinfeld, 6/26/2013

adamw


6,803 post(s)
#01-Mar-17 15:08

The newer build is trying to uninstall the older build. That requires the MSI for the older build. All installed MSIs are normally cached by the operating system, but sometimes that breaks (and sometimes the mechanism is not engaged due to how the system is configured / how exactly the install is performed). That's why we strongly suggest you keep the MSI for the build you have installed (ie, on this page).

firsttube


1,424 post(s)
#01-Mar-17 17:42

Thanks for that info, Adam. In the event I cannot repair the windows installers and I no longer have the msi file for Radian build 9.0.158.0, is there anywhere I can download the msi file?


"The blessing in life is finding the torture you are comfortable with." - Jerry Seinfeld, 6/26/2013

Dimitri


3,900 post(s)
#01-Mar-17 17:48

The Windows troubleshooter in the link Adam mentioned should do the trick. If you need to look up the product code for .158 for use with the troubleshooter, here is a quote from an adamw post in a beta thread...

Also, you can look up product codes using WMIC - that's a built-in Windows utility (don't know since which version, probably since Windows 7 SP1 / 8, but might be earlier), no administrative rights for listing product codes required.

Eg, this will list product codes for everything with 'Radian' in the name:

wmic product where "Name like '%Radian%'" get Name, Version, IdentifyingNumber

This will list product codes for all installed products:

wmic product get Name, Version, IdentifyingNumber

Hope this helps.

firsttube


1,424 post(s)
#01-Mar-17 17:47

This actually worked: https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

Thanks!


"The blessing in life is finding the torture you are comfortable with." - Jerry Seinfeld, 6/26/2013

antoniocarlos

438 post(s)
#08-Mar-17 00:43

Hi I am having this same problem. Before I try this. How did you use the Microsoft fix?


How soon?

ColinD


1,781 post(s)
#08-Mar-17 04:43

From the link

Follow these steps to automatically repair issues including corrupted registry keys that block you from installing or removing programs:

    • Select the Download button on this page.
    • In the File Download dialog box, click Run or Open, and then follow the steps in in the Program Install and Uninstall Troubleshooter.

Aussie Nature Shots

antoniocarlos

438 post(s)
#08-Mar-17 11:40

Thanks.

It worked, but I had uninstall Avira and use the account I used to install Radian before it worked properly.

BTW Avira was also giving me a false negative with the Radian installation.


How soon?

rockharrier2 post(s)
#08-Mar-17 23:53

I was having the same issue trying to uninstall Radian 9.0.158. I ran the Microsoft fix listed above, and it did uninstall. However, I am still getting a similar error when I try to install 9.0.159. (see attached screenshot). Any ideas on how to resolve this? Really want to get some form of Radian back on my computer...

I do have Manifold 8.x also installed. Do I need to uninstall Manifold in order to install Radian??

Attachments:
radian_error.PNG

tjhb

7,191 post(s)
#09-Mar-17 00:05

Have you reviewed the installation prerequisites?

(And no, Manifold 8 and Radian Studio are designed to play nicely together.)

adamw


6,803 post(s)
#09-Mar-17 08:12

First off, while you are resolving installation issues, you can use a portable install of Radian. If you already had Radian installed and activated, you can just unpack the portable install archive and run from there. You won't have MAP file associations and if you want to use the ODBC driver, you have to register it manually, but that's about it.

On to the installation issue - it would be helpful to see the log file. You can capture the log file by installing using the following command line - open a command prompt with Administrator privileges:

msiexec /i manifold-9.0.159-x64.msi /l*v log.txt

The log file is going to be written into log.txt.

I suspect the problem is in the post-installation step which attempts to launch Radian binaries - and they refuse to launch. This might mean that you don't have the installation prerequisites installed (like Tim says, although if you already had Radian installed before, perhaps that's not it), or that some of the files were blocked by an antivirus or a similar system scanning tool. To be sure it is not the latter, turn all antivirus-like tools off before trying to install. (To be sure the install is safe, verify its hash sum, as explained, for example, here - see the discussion on SHA checksums.)

Hope this helps. If not, contact tech@, they will work it out.

rockharrier2 post(s)
#09-Mar-17 15:41

Thank you for the input, this has been resolved. I was able to complete the install once I disabled my Bitdefender anti-virus. Kind of funny I was able to install Radian 9.0.158 with Bitdefender turned on.

All is well!

Cheers,

mulliken

166 post(s)
#09-Mar-17 17:01

I had the same experience with Norton 360

adamw


6,803 post(s)
#10-Mar-17 07:37

If the checksums of the installation packages verify against those published on the web site, these are false positives.

There was a recent thread on this (the post explaining why these positives exist, replies to that post contain illustrations of tools reacting to completely innocent code like the default example application generated by Visual Studio - you launch Visual Studio, create a new application, compile it, upload the .exe to virustotal - bam, the .exe gets flagged as supposedly malicious).

Manifold User Community Use Agreement Copyright (C) 2007-2011 Manifold Software Limited. All rights reserved.