Subscribe to this thread
Home - General / All posts - Import Excel file error
firsttube


1,437 post(s)
#15-Jun-17 18:08

I can successfully import an Excel file into Manifold 8.30.0.0 running in 32-bit mode on Windows 7 SP1 64-bit. When I try to import the same file into Manifold 8.0.29.0 running in 32-bit mode on Windows Server 2008 64-bit SP2 I get an error :

"Can't Establish connection to data source: error binding to data source." and then "Unknown error"

Is this something that was fixed in 8.0.30.0 ?


"The blessing in life is finding the torture you are comfortable with." - Jerry Seinfeld, 6/26/2013

Dimitri

5,082 post(s)
#15-Jun-17 20:11

Is this something that was fixed in 8.0.30.0 ?

The release notes for 8.0.30 are in the announcement - anything that was fixed would be in there. I don't see anything in there related to what you describe... perhaps you could take a look and double-check in case I missed something.

It's also wise to consider that anomalies like you mention rarely are about something that needs to be fixed in the product, especially something as proven as 8. It's usually something else having to do with operational matters, like somebody else using the file, a lock of some kind by a process, permissions, etc. I'd start with a very detailed look in those areas first. Might help to use the exact same setup on the same computers, etc., to narrow down possibilities, as the one thing you know about comparing results on two different systems is that the two systems are different.

adamw


8,216 post(s)
#16-Jun-17 07:03

Is this something that was fixed in 8.0.30.0 ?

I re-checked and I don't see any related changed between 8.0.29 and 8.0.30 for that.

(I'd still try to use 8.0.30 over 8.0.29 given a chance, but in terms of why the second machine fails to connect while the first succeeds, I'd look elsewhere.)

ranger.sean79 post(s)
#27-Jun-17 06:11

Hi all,

Just wondering if anyone else is getting the same error message as the original poster when attempting to import a table from Excel in Mfd 8.0.30?

I have 32 and 64 bit versions of 8.0.30 running on the same machine, but while the 32 bit version imports fine, the 64 bit version errors out with the same message as the original poster received. I've tried several types of Excel file (97 and 2007) but each results in the same error in 64 bit Mfd.

My question is - given the import works okay in Mfd 32 bit, is the error in 64 bit Mfd running on the same machine likely to be permissions or process related?

Any help appreciated.

Sean

danb


1,665 post(s)
#27-Jun-17 06:20

Hi Sean, have a look in the help searching for 'jet'. In the topic '32-bit and 64-bit Manifold Editions', scroll down to the section 'Limitations of 64-bit Editions' and you will find the answer.


Landsystems Ltd ... Know your land | www.landsystems.co.nz

ranger.sean79 post(s)
#27-Jun-17 08:14

Thanks Dan - that appears to cover it off perfectly.

Cheers

volker

1,030 post(s)
#16-Aug-17 09:03

In Radian Studio 9.0.162.0 64bit, i'm not able to Import a xlsx-File.

I can link it, but if i clicked on the linked table nothing happens...?

As a data source don't work, too.

All the same with a xls-File.

Open the file in Excel save as DBase IV, Radian Import the file but only 2 rows of 20.

My Experience with database:

i make a data source to my SQLServer 2014, all fine but if i look at the linked tables there are not all rows.

In Manifold 8 no Problems with this ?


http://www.thegisservicesector.de

adamw


8,216 post(s)
#16-Aug-17 09:16

Can Manifold 8 open XLS / XLSX file? If so, is the instance of Manifold 8 that can do this 32-bit or 64-bit?

If a 64-bit version of Manifold 8 can open XLS / XLSX, but a 64-bit version of Radian cannot, we need to look at the file. Either post it here, or contact tech support. (If the issue happens with any file, just create a model file with a couple of values, make sure it can be used to reproduce the issue and post it.)

Thanks for the report.

volker

1,030 post(s)
#16-Aug-17 09:39

Manifold 8 can open the xls-File in 32bit in 64bit "can't establish Connection to data source..."

But what is withe the dbf-import in Radian and the SqlServer data source ?


http://www.thegisservicesector.de

adamw


8,216 post(s)
#16-Aug-17 09:45

If Manifold 8 can open the XLS file in 32-bit, try 32-bit Radian as well. If the 32-bit Radian cannot open the file, then that's an issue, otherwise (if 32-bit Radian can open the file, but 64-bit cannot) it is probably just that you don't have the 64-bit Access Database Engine installed.

We need more details regarding DBF and SQL Server.

DBF: Could you post the DBF file that contains more than 2 rows but imports in Radian as only 2? If the data is confidential, contact tech support.

SQL Server: What specifically happens? You are connecting to SQL Server in Radian, open one of the tables and only get a couple of rows, but not all of them, correct? If so, is the table stored on SQL Server or is it some special table, like a view or, say, an ODBC fallthrough? What indexes does Radian detect (what's in the schema dialog)? Do you get all records if you try copying this table using SELECT INTO to a table in a MAP file (SELECT * INTO [tablecopy] FROM [sqlserver]::[table])?

volker

1,030 post(s)
#06-Dec-17 13:06

as i describe in my post from 16. August it's still the same problem in the actual Future .11:

if i do a database connection to SQLServer there are not all rows of my database table.

Have a look at the attachement...

Attachments:
database connection in Manifold Future.doc


http://www.thegisservicesector.de

adamw


8,216 post(s)
#06-Dec-17 13:45

The fields look wildly different. It seems to me that Manifold 8 and Future are showing different tables - whose fields are the correct ones?

Does the difference disappear if you copy the table with a name with English-only letters?

In any case, could you make a backup of the database and upload it somewhere?

volker

1,030 post(s)
#06-Dec-17 15:43

Manifold 8 shows the correct tables with all rows.

Does the difference disappear if you copy the table with a name with English-only letters?

-> i will give a try

In any case, could you make a backup of the database and upload it somewhere?

-> i do a backup and copy it to my Dropbox

Should i post the link to Manifold Tech ?


http://www.thegisservicesector.de

adamw


8,216 post(s)
#06-Dec-17 15:49

Yes, post the link to tech support, please. We don't need all records, you can delete all but a couple in each table (and you can delete all tables except those necessary to exhibit the issue) to save time uploading / reduce the impact in terms of sharing potentially sensitive data.

Thanks a lot in advance!

adamw


8,216 post(s)
#13-Dec-17 16:45

This should work correctly in 9.0.163.12.

The fix was a pretty big change, but that's semantics, we agree that Unicode names for database objects are important (it is just unfortunate that supporting them requires doing pretty different things for different databases).

dchall8
512 post(s)
#03-Jan-18 17:36

I got the same problem with M 9.0.164 today. Here's the log dump

2018-01-03 10:55:33 *** (import) Provider=Microsoft.ACE.OLEDB.16.0;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.ACE.OLEDB.15.0;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.ACE.OLEDB.14.0;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.ACE.OLEDB.12.0;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.Jet.OLEDB.4.0;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.Jet.OLEDB.4.0;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.Jet.OLEDB.4.0;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.Jet.OLEDB.4.0;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.Jet.OLEDB.3.51;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.Jet.OLEDB.3.51;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.Jet.OLEDB.3.51;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:33 *** (import) Provider=Microsoft.Jet.OLEDB.3.51;... Error code: -2147467259 (REGDB_E_CLASSNOTREG)

2018-01-03 10:55:34 *** (import) Provider=MSDASQL.1;... [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

2018-01-03 10:55:34 *** (import) Provider=MSDASQL.1;... [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

2018-01-03 10:55:34 -- Import: C:\Users\dhall\Documents\Spreadsheets\PACS 2018-01-03.xlsx (0.352 sec)

I'm using Win 7 with Excel from MS Office 2013. All the updates are installed by a contractor nightly as updates are available.

I will bring it in with CSV for now.

adamw


8,216 post(s)
#04-Jan-18 06:25

I don't think it is the same problem.

The problem that volker was experiencing was related to tables having names with non-English characters.

The problem in the log above is that 9 is trying to connect to an XLSX file using Jet, tries various version of Jet it supports going from most preferable to least preferable, and fails to instantiate any of them. It looks like the usual 32-bit / 64-bit issue - 64-bit Jet normally has to be installed separately (see Access 2013 Runtime, for example). If you were connecting in 64-bit mode (likely), make sure you have 64-bit Jet (eg, a 64-bit package from the above link) installed. If you were connecting in 32-bit mode, make sure you have 32-bit Jet installed.

dchall8
512 post(s)
#04-Jan-18 15:40

Okay, how long has the Access 2013 Runtime solution been known? I'm guessing since 2013 based on the name. Somehow I missed that. I just assumed the problem had never been addressed and would be fixed sometime in the future with an update to M8. So now I can import .xlsx spreadsheets directly into M8 64-bit - sweet! That saves a step or two.

I had to fix another issue when setting up the Access 2013 Runtime. I needed to uninstall ‘Office 15 Click-to-Run Extensibility Component’ as described here...which I would have linked to but the link button isn't doing anything. Google the stuff in quotes and you'll find it at itsupportguides.com.

Dimitri

5,082 post(s)
#05-Jan-18 05:31

I just assumed the problem had never been addressed and would be fixed sometime in the future with an update to M8.

Perhaps I misunderstand your comment, but it seems you are missing the point. The issue you appear to be experiencing is a well-known, well-documented and well-discussed *Microsoft* phenomenon. It is not specific to any of the many tens of thousands of applications that connect to "Access" or "jet" style files in 32bit/64bit windows. If you want to operate 64-bit Windows it is part of the *Microsoft* landscape you must navigate.

Microsoft's failure sensibly to migrate Jet into 64-bit environments is well-known, and the endless hassles arising from Microsoft's various attempts to deal with the non-64-bitness of Jet (such as a 64-bit quasi-Jet engine that is incompatible with most of the Office installed base) are also well-documented and discussed, even within Manifold documentation.

Manifold has no ability within updates to any Manifold software to remedy that, no more than Manifold can issue an update to 8 that will prevent Windows 10 from seizing your system at the least convenient moment to install yet another Windows 10 update. The best Manifold can do, which Manifold does, is to provide tremendous flexibility so that whatever can be done is done, and that a wide range of options are supported for informed users who prefer to choose their own way of dealing with the subtleties arising from widespread use of a Microsoft technology, Jet, within applications that Microsoft no longer smoothly supports in 64-bit Windows.

I had to fix another issue when setting up the Access 2013 Runtime. I needed to uninstall ‘Office 15 Click-to-Run Extensibility Component’ as described here...which I would have linked to but the link button isn't doing anything. Google the stuff in quotes and you'll find it at itsupportguides.com.

Very well-known issues in Windows, which is why you find numerous hits about that stuff from Google on *windows* forums, where such discussions belong. Manifold products contact Windows and other products (such as SQL Server, Oracle, etc, etc.) at numerous places, part of routine interoperability. But once you identify something as being a highly generic Windows thing and not remotely unique to Manifold, it's time to leverage Windows-specific informational resources.

dchall8
512 post(s)
#05-Jan-18 18:28

Just to complete the thought on this, another non Manifold issue arises. For those others who might do what I did with the jet trick, it prompts warnings in the other Office products. They seem to work but you get a message when they open. So to bring this back to Manifold, you may as well continue to import .xls files into Manifold 8 32 bit instead of changing the jet. I would call that a jet hack rather than a jet fix.

KlausDE

6,232 post(s)
#15-Oct-17 15:47

This is a bit mysterious. I know a could import XLS and XSLX-files in Mfd8 but in 8.0.29.0 I can't any longer in 32 bit mode and 64 bit mode. The error reported is "can't establish Connection to data source...". No machine with 30.0 at hand in this moment.

On the same machine MF 163.5 doesn't import this very simple files neighter in 32 bit nor in 64 bit mode and quits import without error message.

Could this be a side effect of an update of the operation system? Running MS Office 2013 on this machine.

Attachments:
Mappe.xls
Mappe.xlsx

Dimitri

5,082 post(s)
#15-Oct-17 16:15

I launched Manifold Future 9.0.163.5 from the Bin folder (32 bit) and both imported fine for me.

Attachments:
xls_xlsx.png

KlausDE

6,232 post(s)
#15-Oct-17 18:40

I avoided dates and floats so that regional settings might no interfere. I'll check more machines and ancillary conditions.

tomasfa
149 post(s)
#19-Oct-17 20:30

Hi. I have these same issue with Mf8 30 and with MF163.5. My xls has dates and some regional settings, which I need. It gives the error mentioned above, same as KalusDE. Cant connect... and also a message box with Unknown error.

I solved it, changing the format from XLSX, into CSV and import went perfectly. Just to let you know.

Best regards.

KlausDE

6,232 post(s)
#19-Oct-17 20:58

What's the regional settings of your machine? OS version 10, 8 or 7? There must be some special marginal condition.

rk
276 post(s)
#19-Oct-17 22:01

Could this be a side effect of an update of the operation system?

Probably yes. KB4041676

KlausDE

6,232 post(s)
#23-Oct-17 16:13

BTW same effect with Mfd 8.0.30. on a german Win7_Prof 64x

I have solved the issue for Mfd_x64 by installing the AccessDatabaseEngine_X64 following the workaround published for rk's link.

I can't use this workaround for x86, because that would break my existing MS Office x86 installation.

WernerDE5 post(s)
#23-Oct-17 16:45

Deinstallation and hiding KB4041681 solved the issue for me with Mfd 8 on a german Win7_Prof 64x. Works with Mfd_x32. Hoping that MS will fix this problem with JET in the next update.

fishmap50 post(s)
#23-Oct-17 23:27

Its an issue exporting as well. had a couple clients complain to me about it...I just told them to export a csv for now

Manifold User Community Use Agreement Copyright (C) 2007-2017 Manifold Software Limited. All rights reserved.