Subscribe to this thread
Home - General / All posts - Manifold image server not working anymore??
Corentin35 post(s)
#11-Jul-17 11:36

Hello,

I am using Manifold v8.0.28 and my linked images to google servers of satellites images are not working anymore.

I have some .map files where I had added linked satellites images, those images where working well few days ago, I could open them and overlay them to my maps. Today for no apparent reason it is not working anymore (I can open the component image but it is empty)

When I try to import new images I got the message "no Manifold image server installed"

In the firm where I work we are several colleagues using manifold, two of them have exactly the same problem (Manifold V8.0.30 and Manifold V8.0.28), for one of them it is still working (both opening old linked images and creating new one)

What is happening? Should we all install Manifold V8.0.29?

adamw

7,102 post(s)
#11-Jul-17 12:32

If something was working before and is no longer working now, look for what has changed.

Were there any updates installed? Any antivirus software? Are the image server DLLs still there and not locked (view file properties in Windows Explorer and if the General tab displays an 'Unlock' checkbox, well, something locked the file and it has to be unlocked now else Windows will refuse to load it)? Etc.

Alternatively, get it working from scratch: upgrade to 8.0.30 (the latest version), redownload the image servers from the main web site (unlock the archive if the browser marks it as locked, then unzip it into the correct folder), then try using it. Make sure the cache folder location is correct and the drive it is on has some free space.

Corentin35 post(s)
#11-Jul-17 14:36

Nothing new was installed. For the computer with 8.0.30 version it is brand new, last week it was working... Nothing special was installed on this machine.

I tried to redownload the image servers from scratch, I unblocked them, unzipp and copy past in the manifold folder but nothing changed. I tried to disable my antivirus, but it has no effect...

The Cache folder is ok. I have free space on my drive...

Btw I tried to link to datasource in Manifold Viewer, and there I can have image servers so my internet connection seems not to be to blame...

Dimitri

4,107 post(s)
online
#11-Jul-17 16:02

Sounds like a permissions issue or something else having to do with administration of your Windows system. It's not Manifold.

Search the forum and read the threads on permissions issues, etc.

For the computer with 8.0.30 version it is brand new, last week it was working... Nothing special was installed on this machine.

If it was working last week and it is not working this week, then something has changed on the machine between last week and this week. Zero in on what was changed in terms of Windows admin, antivirus, etc., and that will likely clear up the mystery.

adamw

7,102 post(s)
#11-Jul-17 16:32

You said invoking File - Link - Image, Manifold Image Servers results in the error "No Manifold Image Servers installed", correct? As in, you don't even get to the Link dialog. The installation of Manifold always includes at least one image server - for Manifold web sites - partly so that this dialog always has something to work with. If you get the error, it looks like that built-in image server also does not load.

Check if the following DLLs are in the Manifold folder and are unlocked:

  • manifold.imageserver.manifoldims.dll
  • manifold.imageserver.dll

If you installed a 64-bit version of Manifold 8, there are two folders - one for 32-bit and another for 64-bit - check the one for the flavor of Manifold that you are usually running.

If the DLLs are there and unlocked, uninstall and reinstall Manifold. (If there is a problem during uninstall, that's likely what prevented the image servers from working.)

Corentin35 post(s)
#17-Jul-17 14:50

Yes, the error message is "No Manifold image servers installed". And we don't get the link dialog.

I tried to uninstall and reinstall manifold (uninstall V8.0.28 and reinstall V8.0.30 then V8.0.29) on my computer, it is still not working; The manifold.imageserver.manifoldims.dll and manifold.imageserver.dll are not blocked. And it is still not working...

On one of the computers I get the link dialog but then I get "Can't create Folder" (Manifold V8.0.27)

On 9 computers

  • 7 are not working :

-6 with the error message "No manifold image server installed" (V8.0.28; V8.0.29; V8.0.30)

-1 with the error "can't create folder" (V8.0.27)

  • 2 are working (V8.0.29 & V8.0.26)

Most of computers are 64bits but running Manifold 32bit

All antivirus are the same...

Any ideas?

tjhb

7,364 post(s)
#17-Jul-17 16:28

Looks like you may be missing .NET 4? Manifold 8.0.29 requires this. (Earlier versions required .NET 2.0.)

.NET 4.x is installed out of the box with Windows 8 and above, but if you are running Windows 7 or earlier and have not updated then you may have .NET 3.5. In that case install .NET 4.5 or later.

See System Requirements.

As I understand it, current versions of the Image Server modules require .NET 4.x, and will therefore not work with versions of Manifold earlier than 8.0.29. Also, NET 2.0 is not installed by default with Windows 10, though you can add it.

In a nutshell, make sure all machines are running 8.0.29 or 8.0.30 and have .NET version 4.0 or above.

adamw

7,102 post(s)
#18-Jul-17 06:47

In addition to what Tim says (he is right, it can be related to .NET 4, make sure it is installed - just run the installer from Microsoft and if it is already installed, it will say so and do nothing)...

Do you have Manifold Toolbar, by any chance? If you do, uninstall it. (Uninstall whatever version of Manifold 8 you have, uninstall Manifold Toolbar, install Manifold 8.0.30.) It comes with its own version of image server DLLs and these are outdated. It shouldn't normally interfere, but we are already looking at something abnormal, so it might be that.

On the computer that fails with "Can't create folder", check the Data Cache folder location in Tools - Options. It should point to a folder that exists and is writable.

Corentin35 post(s)
#18-Jul-17 09:06

Thank for your answers but it is still not working

I have unistalled manifold; then installed the framework .NET V4.6.2 then reinstalled manifold V8.0.30. Nothing changed I get again the message "no manifold image servers installed", then I emptied my Temp folder. The data cache is configured in manifold to be at %MyDocuments% and there I found some folder with OpenStreetMap Images and GoogleEarth Images, I deleted these folders, still not working. I deactivate my antivirus, still not working. I tried to change the internet connection and connect through my smartphone instead of the Wifi of my firm, still not working...

adamw

7,102 post(s)
#18-Jul-17 10:16

Could you archive the contents of your Manifold folder, then upload the archive somewhere and post a link?

Corentin35 post(s)
#18-Jul-17 12:58

I finally had it to work. You gave me indirectly the way to find what was wrong : thank you very much!

I cannot archive the content of my manifold folder and send it on the forum: it contains softwares we develop internally. These software have dlls that are run by manifold in the manifold folder. When I remove some of these dll the manifold image server is working. It may be related to the way we protect our software, but we still have to investigate this point. (It is when I read your post about sending an archive of my manifold folder that gave me the idea of removing our own dll from the manifold folder)

What is strange is that it is not always the same dll that have to be removed from manifold folder.

Thank you very much, we havn't yet found the solution, but we found what files were wrong that is 90% of the solution!

Maybe it is an automatic update of the protection software that has caused the problem...

adamw

7,102 post(s)
#18-Jul-17 13:31

Great!

Corentin35 post(s)
#19-Jul-17 14:30

For the error "Can't create Folder" it is link to our antivirus who detects Manifold has a ransom software and block it when it tries to create the folder to import satellites images...

To solve that one just have to put Manifold on the safe list of the antivirus

atomek

419 post(s)
#18-Jul-17 11:27

I'm encountering the same issue. Fresh install of Manifold 8.0.30, "File > Link > Image > Manifold Image Server" took me to the usual link server dialog, but when I added the image server dll's it suddenly started throwing the same error ("no Manifold image server installed"). Dll's are copied to both Program Files folders and unblocked.

atomek

419 post(s)
#18-Jul-17 12:31

False alarm, sorry. Solved now. Blocked dll's weren't the case, I had to unblock the zip archive before unpacking it.

volker

1,003 post(s)
#11-Sep-17 17:02

Is it possible To integrate this AS an Image Server (in manifold or radian):

Https://S2maps.eu ?


http://www.thegisservicesector.de

adamw

7,102 post(s)
#11-Sep-17 18:02

They say they expose data via WMS and WMTS. We support both, you can try using that.

Dimitri

4,107 post(s)
online
#12-Sep-17 09:58

I've checked and it works fine in both WMS and WMTS. Attached is a zipped .map with the WMTS version.

As the Comments in that project discuss, this is very cool data and a very generous effort that is marred by an unfortunate misuse of EPSG.

The layers from the Eox WMTS server (same in the WMS service) are available in two forms: one which uses the EPSG:4326, Latitude / Longitude coordinate system, and a "3857" version that claims to use Pseudo-Mercator like Google. Besides the main "cloudless" work product there are many very cool and useful accessory layers.

However, only those two "3857" layers that are found in GoogleMapsCompatible subfolders:

s2cloudless_3857_GoogleMapsCompatible Image

terrain-light_3857_GoogleMapsCompatible Image

...are actually in the EPSG:3857 coordinate system used by Google, etc. Lucky for those seeking a good "cloudless" data set, the main work product correctly uses EPSG:3857.

All of the other "3857" layers use a fake "EPSG" code of 900913. There is no such EPSG code in the EPSG database and never has been. 900913 is "google" spelled as numbers (the "9" looks like a "g") and was used by some people as a name for what they thought was Google's coordinate system before EPSG:3857 became the universal standard for Google-style Pseudo-Mercator. But "900913" is not the same coordinate system as EPSG:3857.

Therefore, except for the two "3857" layers which correctly use EPSG:3857 you should always use the non-3857 layer versions. Those are in Latitude / Longitude but Future will re-project those on the fly so you can use them together with genuine EPSG:3857 layers like Google with no problem.

Hopefully, Eox will fix the problem so their "3857" layers use EPSG:3857 and not a fake 900913 code. This project will not need to change when they do that since the project gets all coordinate system information from the Eox servers on the fly.

It will be easy to check if Eox has fixed the fake-code problem:

Open the "3857" layer of interest and see what the Contents pane reports for the coordinate system. If it reports Pseudo Mercator (EPSG:90913) in red letters you know they haven't corrected the data set. If it reports WGS 84 / Pseudo-Mercator (EPSG:3857) in black letters you know they have corrected the problem.

Until the "3857" layers get corrected, just use the Lat / Lon versions of those layers (most of them) which do not correctly use 3857.

Anyway, this is a very generous service from Eox for which they should be commended. Yeah, some of the layers don't use 3857 correctly but that's no big deal given they thoughtfully provided lat/lon versions as well. I'm confident they'll get it fixed quickly.

Attachments:
s2 EOX server.zip

volker

1,003 post(s)
#13-Sep-17 16:40

Hey thank you, that works !


http://www.thegisservicesector.de

Manifold User Community Use Agreement Copyright (C) 2007-2017 Manifold Software Limited. All rights reserved.