Subscribe to this thread
Home - General / All posts - Invalid Field - Can't open radian project - Any thoughts on this one?
tgazzard112 post(s)
#08-Aug-17 11:34

I have 3 radian projects that I can't open. Instead they return

I tried opening by:

1) double clicking on the files - radian opens but returns the above message

2) opening radian and opening through the file drop down menu - same message as above

3) linking the project - I get no message and no action.

All three projects were working up until I closed them.

They are all large projects 7Gb / 8Gb / 66Gb.

All had large tables (between 40million and 100 million records) created in the projects using sql.

They are all produced with an expanded sequence as partially shown in this thread :

http://www.georeference.org/forum/t137516.25

I have tried to replicate this error but am yet to be able to reproduce. I wondered whether this could be due to the RAM being exceeded (I have 64GB RAM) when I saved the project. My paging file size was around 70000 MB at the time. I will try and replicate this again and see. I note there is a spike in RAM when you initially press save with large files with newly created large tables.

The 66GB File had some long run and save times. But I continued to work with this project afterwards and did other actions.

2017-08-03 00:04:06-- Query: [query_tes] (40044.118 sec)

2017-08-03 07:19:46-- Save: D:\radiant heat calcs_v9.map (1593.692 sec)

The first two where produced using 9.0.162 but I had transitioned across to 9.0.162.3 by the third one.

I have tried to replicate this error but am yet to be able to reproduce. I wondered whether this could be due to the RAM being exceeded (I have 64GB RAM) when I saved the project. My paging file size was around 70000 MB at the time.

I have a D drive and C drive - both 1 terabyte each. The first two where on the D drive. The last one on the C drive.

I know this is a bit vague - but thought someone else might have encountered this? Or might have some suggestions as to where to look.

adamw

7,031 post(s)
#08-Aug-17 12:36

This is pretty bad.

I doubt the issue is related to spikes in use of RAM during save - having to use the pagefile sometimes is completely normal and expected.

Could you upload one of the files (perhaps the smallest one) to tech support? They will provide FTP info upon request if you don't already have it from prior communications - email tech@manifold.net, say that you want to report a potential issue and do not require a response, link to this thread and offer to send the data.

Even better would be a process of creating such a file, but I realize this might be difficult (the log for creating any of the files is likely big - although if it isn't, we'd be happy to let the test machines try to recreate the issue using your queries / original data or synthesized data).

artlembo


2,784 post(s)
#08-Aug-17 13:11

I run into this a lot. Usually when running a heavy duty transform and then canceling it. For me, it isn't when opening a file, but rather when attempting to double-click a table, drawing, or expand a folder.

However, unlike tgazzard, I can usually close everything and then re-open it, and it works again. If I come across this again, I'll make more of a point to document things.

adamw

7,031 post(s)
#08-Aug-17 13:27

Yes, please let us know when this happens. This isn't normal.

(We never saw any of this in tests. We are going to extend them, both in general and in a more focused manner once we understand which specific part of code is responsible for the issues.)

Dimitri

4,024 post(s)
#08-Aug-17 14:22

I run into this a lot.

I'm mildly shocked this is the first time we hear about it. If there is *anything* wrong or unexpected, please speak up right away so it can be immediately diagnosed and repaired. Until this thread with one exception this is the first anybody's heard a report of that error message.

Besides the obvious possibility of a simple bug within Radian, two other possibilities come to mind:

First, that one exception mentioned above is that occasionally we've seen that message when re-opening with current Radian .map projects saved by experimental alpha or beta builds of Radian back when .map format was still being changed in significant ways. We would not normally count that since such experimental formats are not expected to work at all, and no such issues have appeared in tests with the released product or .map format used by the released product. Since you were in the beta, could it be you were using data stored in one of those experimental .map formats?

Second, I have to ask given the discussion in the other thread: could you be encountering this a lot because you are canceling a transform with a CTRL-ALT-DEL a lot? If that is the case and you make it a point to cancel using CANCEL (however long that takes), does the error message thereafter stop appearing?

artlembo


2,784 post(s)
#08-Aug-17 14:41

Manifold has been hearing a lot from me, but not via the forum - there have been numerous emails to tech as well as a contact at Manifold, and a bunch of .map files posted on the FTP site to support the issues I've run into (in fact, at least 6 in the last 5 days).

Simply put, like everyone else on this forum, we are doing this as volunteers. So, the fact that I've spent the amount of time I have on discovering issues and reporting them through the various channels should not be a surprise that I had not said anything about the Invalid Field issue. In fact, most of what I send to tech and an internal contact are only after I have run into the issue numerous times and can recreate the issue myself and post data. Some times, when posting gigabyte sized .map files, the ftp takes hours to upload - trust me, I'm giving this my best effort given the time I have available to explore these things.

As for the beta build, I don't think that is the case. All of the times I've seen this error are with the newer projects I've created. I just assumed it might have been a resource issue on my computer, so that is why I've just quit out of the application and restarted it.

Canceling (however long that takes) is not really an option, especially when I've waited 100 minutes for cancel to work.

And once again, as I've said elsewhere, if I see this crop up again, I will try and determine what I was doing at the time so that I can provide you with more details.

Dimitri

4,024 post(s)
#08-Aug-17 15:00

Art, I didn't want to give the wrong impression - my fault. Everybody appreciates your feedback and the bug reports you provide. I just want to emphasize that anything you encounter you don't like, is any sort of problem, any possible bug or just is unexpected, report it and it will get fixed immediately.

volker

1,001 post(s)
#09-Aug-17 09:42

in Radian 9.0.162. 64bit Version i want to Topology Overlay with the UNION function

two Area-Drawings, imported from mif-format:

there are not really big files.

MFD 8 64bit does the same in a few minutes without an error...?

Here is the result of Radian:


http://www.thegisservicesector.de

Dimitri

4,024 post(s)
#09-Aug-17 10:38

Could you post those or upload them somewhere?

volker

1,001 post(s)
#09-Aug-17 11:05

i copy it on my dropbox. Could you give me an email adress for the dropbox link ?

i don't want to copy the dropbox link for the public...


http://www.thegisservicesector.de

Dimitri

4,024 post(s)
#09-Aug-17 12:09

Sure, just send to tech@manifold.net (with a note about what the link is for...) Thanks for uploading the data!

Also... *so* cool to see Radian in German. Thanks Klaus!

volker

1,001 post(s)
#09-Aug-17 12:51

Done.

Yes Radian in german is cool.

Thx to Klaus, too !!!


http://www.thegisservicesector.de

tgazzard112 post(s)
#13-Aug-17 06:06

Thanks for the advice on this.

I will upload the smallest file to dropbox and send it through to email address above today.

In regards to the log. I assume that you mean the log that typical sits in the ...appdata\local\manifold\v9.0

I am not sure this will be that helpful as I would of copied and pasted in a lot of different queries or query sequences into the query named "Query". But happy to provide if this helps.

Manifold User Community Use Agreement Copyright (C) 2007-2017 Manifold Software Limited. All rights reserved.