Subscribe to this thread
Home - General / All posts - Geocoding with Radian - stopped working
artlembo


2,819 post(s)
#08-Aug-17 16:23

Has anyone attempted to use the Google geocoder lately? Up until a few days ago it was working, but now it isn't:

-- $manifold$

VALUES (GeocodeAddress([google]'16 Bush Lane Ithaca NY'))

Can someone try and geocode the above address? (I have a data service called [google] that uses the Google Geocoding service).

adamw


7,129 post(s)
#08-Aug-17 16:42

Returns [ -76.48660699999999, 42.495071 ] for me. No API key.

artlembo


2,819 post(s)
#08-Aug-17 16:49

thanks Adam. Both my home computer and my office computer return NULL. I did run a query on a larger data set, but that was 2 days ago, so I couldn't have hit the limit just yet.

I also tried it with an API key and had the same results. Tried it with Bing, too. Same issue.

Dimitri

4,118 post(s)
#08-Aug-17 19:49

Did you create a data source named [google] that is a Web Server: geocodeserver using the Google Geocoder?

When I read this thread I copied and pasted the SQL into a Command window, ran it with ! and got a <NULL> and thought ... "whoa... doesn't work for me either." And then I realized I had not yet created the geocodeserver data source. I did that, re-ran the query and voila! same result as adamw reported, also no need for an API key.

danb


1,581 post(s)
#08-Aug-17 20:14

Same result as Adam for me (once I had created the data source). Null without.


Landsystems Ltd ... Know your land | www.landsystems.co.nz

artlembo


2,819 post(s)
#08-Aug-17 21:21

good thought, but in this case, it was running the other day, and now doesn't run. So, everything has stayed the same.

I decided to create a new geocoding serrvice from scratch (see attached video), and the same thing. I just get NULL.

I wonder if there were updates at work that might be blocking incoming traffic from the geocoding servers. I doubt it, because the image servers work just fine.

Attachments:
geocode_error.mp4

adamw


7,129 post(s)
#09-Aug-17 06:22

It is hard to say what the issue is. Several things to look into:

1. Is there anything in the log? (Just checking all bases.)

2. Try a different address. Better the one you never tried.

3. Clear browser cache and try one more address.

I suppose we could then get down to trying a specific request in the browser and looking at the response, but it's unlikely that the response is good...

artlembo


2,819 post(s)
#09-Aug-17 13:37

It is working today. I suspect it had to do with the number of addresses I geocoded previously. Even though it was over 24 hours previous, I suspect that Google's lock on my IP address was greater than 24 hours.

I have another 2,000 addresses I can test, so that should throttle it again, and I will see if the log file gives any indication of that.

p.s. on another note, I canceled a long geocoding process, and the cancellation is taking forever. So, that is another example of the problem with using the cancel button.

artlembo


2,819 post(s)
#09-Aug-17 17:25

that was it. I ran the process again, and now I am getting:

(root)::[google] REQUEST_DENIED

so, I must have exceeded Google's limit.

I was just surprised that it was still dead after 24 hours.

lionel94 post(s)
#10-Aug-17 20:00

go to gogole map API documentation to know the limit

There is limitation for the request map but also some service inside map API

general https://developers.google.com/maps/documentation/javascript/usage

geocoding https://developers.google.com/maps/documentation/javascript/geocoding#UsageLimits

like every service there are limit and strange ( happy sense ) there is an elevation service !!!

Best is to buy a VPN that let you change the ip to any country !!!! evey ISP should offer to have more subscribers but not a lot until now !!!!

@art i was thinking you know this limitation ....... as a developer ( i am myself a web dev ...not desktop)

I Read somewhere don't know when than some service base on google map go to osm to geocode ( don't know if it is about map or geocode ) but don't have documentation information and never search about free osm map geocoding service .

For voice to text the Voice API ( wonderfull , efficient ) also limit the number of character that can be translate at once . But can be use for domotic since command to trigger action are often less than 4 words !! ( microsoft translator on android is a tool to try ...)

lionel94 post(s)
#10-Aug-17 20:17

from stackoverflow at https://stackoverflow.com/questions/2063093/how-do-i-do-geocoding-and-routing-with-openstreetmap

The geocoders currently used on OpenStreetMap's main site are Nominatim and GeoNames. There is now also an open geocoding service by MapQuest.

For osm general service ( search) go to http://wiki.openstreetmap.org/wiki/Search_engines

Ozi explorer on desktop ( since i use ozi mobile ) use geoname

strange the nominatim seem only support reverse geocoding https://github.com/rdeguzman/python-nominatim

Hope those informations ll be helpfull !!

adamw


7,129 post(s)
#11-Aug-17 06:23

Nice links.

We support MapQuest geocoding already.

GeoNames will be useful for an example of how to build a custom geocoder when we add the API for plugging such things in.

Manifold User Community Use Agreement Copyright (C) 2007-2017 Manifold Software Limited. All rights reserved.