Subscribe to this thread
Home - General / All posts - Whenever I want to create queries, etc. the options are all greyed out...
hsamuel16 post(s)
#08-May-18 18:12

I recently installed Manifold . I just wanted to reach out about my issue. I just created a new data source, linking to my dbf on my personal drive and the table appears but I notice by the "data source" cylinder symbol in the Project panel has a black lock next to it.

When I try to create a new query , ( or create a new anything for that matter) every choice is greyed out. I am unsure why and I don't see any User Help guides with any useful input- any ideas?

tjhb
8,009 post(s)
#08-May-18 18:53

Take the first sentence first. Which version of Manifold did you install (full details), on what OS, and to what folder(s)? Did you successfully activate it?

Then skip the rest of the first paragraph for now and go straight to the second. If you launch a new instance of Manifold—an empty project—can you successfully create a new Comments component?

hsamuel16 post(s)
#08-May-18 19:36

Build 9.0.166.5 (25-Apr-2018)

OS: Windows 7

to my user folder on my C drive.

Yes, on a blank project, I am able to create a new comments/query, etc.

tjhb
8,009 post(s)
#08-May-18 19:57

Good, although...

You must have installed and activated a different version first.

9.0.166.5 is a cutting edge build and can’t be literally “installed”, only unpacked then launched in place.

Often it is important to be exact about this, probably not here.

Dimitri


4,843 post(s)
#08-May-18 19:41

but I notice by the "data source" cylinder symbol in the Project panel has a black lock next to it.

You've created a read-only data source. Can't create anything in that data source since it is read-only, so all the choices to create anything are disabled (grayed out).

tjhb
8,009 post(s)
#08-May-18 19:52

...But you should be able to create queries (or anything else) outside the locked datasource, including in the project root (blank space below).

Queries created in the project root can access (though not update) data in the locked datasource.

hsamuel16 post(s)
#08-May-18 19:56

And how do I do this? How do I write query that will refer to the data source if im writing a query in the project root?

tjhb
8,009 post(s)
#08-May-18 19:58

Ah. As you begin reading the manual, look out for the ‘::’ syntax.

Dimitri


4,843 post(s)
#09-May-18 05:41

ow do I write query that will refer to the data source if im writing a query in the project root?

See this example. If your table is called [My Table] and it is found within a DBM that you have linked into the project with the name [My Big DBF] then in a query that you create in the root you would call it [My Big DBF]::[My Table].

The example shows use of a read-only data source, and a query written in the root of the project.

For a different example see this one. That shows use of a read-only data source that is a web server providing images. It shows how to copy an image and paste it into the root, alter the table it uses to being the one within the data source, and thus converts a read-only thing into something for which the properties can be altered to change the styling.

The current build is 167. Download and install that. It is a regular Windows installer thing that installs Manifold within Windows so you can launch it from the Start button, etc. I personally much prefer the portable installations, since then you don't have to mess with Windows installation idiocy.

About the "create a new project from the installed build" - That's just a different way of saying "Install the latest build of Manifold, 167. Launch Manifold." He's just saying "make a fresh start."

When you launch Manifold it automatically opens up with a new project. You can then link in your DBF and do what you want. See Getting Started:

"Launch Manifold:Launch Manifold and it opens with a new, blank project. "

It's a shame your first experience with Manifold has run into something that gives you read-only access to that DBF. When you are learning a new thing, especially when trying to "wing it" by just applying the thing without reading documentation in the recommended order, it can be really annoying when you run into something like that. In truth, Manifold is pretty easy to pick up for many people even if you "wing it" but not if extraneous things like Windows preventing you from using files pops up. Usually, as the many examples and videos show (see the Gallery page) you just link stuff in that you want to use and Windows isn't going to interpose security measures to save you from yourself.

That "read only" deal is almost certainly something related to Windows security measures, which, of course, are a critically important feature in Windows, one of the many things Windows does in an attempt to prevent people from hurting themselves. You can get around such Windows features quite often in a brute force way by using Run as Administrator when you launch Manifold. But all that is a Windows matter, not Manifold.

Speaking of baffling Windows matters designed to prevent people from hurting themselves, if you've downloaded the DBF from Internet it could be that Windows has, of course without telling you, marked it as a blocked file that should not be used because it might be dangerous. You have to "unblock" it before Windows will let you use it.

One more tip: try downloading some of the example files from the Manifold product downloads page and working through the examples that use them. That will help you get your head around the basics in an efficient way, so that when you run into something abnormal that Windows throws at you, you'll have the confidence to know it is not something arising from your unfamiliarity with Manifold but, instead, a routine matter of something weird being tossed at you from Redmond. :-)

hsamuel16 post(s)
#08-May-18 19:52

I don't understand how I am doing it ... there is a check box underneath that says "open as read only" in the create new data source dialog box and I just repeated adding the data in and I didn't check that box and yet, it's still adding it in with a black lock and not letting me create a new comment, etc.

tjhb
8,009 post(s)
#08-May-18 20:04

First, copy the .dbf to a folder where you know you have full write permissions. Your user Desktop should be a safe bet.

Now make a new project—perhaps using installed version 9.0.166 [corrected] to begin with, not a cutting-edge build—and add a new datasource from the copy.

If that works (not read-only), then it may be that you are missing some permissions on the “personal drive” where the .dbf is originally located.

[Added] Also try making a new project from the installed build (I’m assuming 9.0.166) and creating a new datasource using the original .dbf. If that also works, then there may be a problem with how you are unpacking cutting-edge builds (for example not unblocking before unpacking, important on Windows 7).

hsamuel16 post(s)
#08-May-18 20:52

I tried your advice of adding it from Desktop (after saving it to this location) and it still acts like read-only (black lock)

When you say create a new project from installed build, how exactly is that done. I don't see options to make new projects.

tjhb
8,009 post(s)
#08-May-18 21:46

I tried your advice of adding it from Desktop (after saving it to this location) and it still acts like read-only (black lock)

That's helpful. What version of Manifold 9 did you launch from, in that case? You can check the exact version in Help > About. E.g. 9.0.166.0 (installed) or 9.0.166.5 (cutting edge).

What I would do next is: launch Manifold 9 from the Start Menu (not from a cutting-edge build in your user folder). Again verify in Help > About that you are running an installed build, e.g. 9.0.166.0.

On a clean launch, you already have a new, empty project. (At other times you can use File > New.)

...And try again. What now?

And do you administer your own system? If it is maintained by someone else, they may need to see the symptoms you are seeing, then change their assumptions or the effective permissions.

Dimitri


4,843 post(s)
#09-May-18 12:30

Also, please verify you are using Manifold and not Manifold Viewer. Viewer is read-only.

adamw


7,903 post(s)
#10-May-18 14:51

I suspect this is what Dimitri says - you are using Manifold Viewer and not Manifold 9. Manifold Viewer forces the 'Open as read-only' option onto each data source by design.

But for completeness, for 9, there is one more step to make data writable in addition to putting the files into a folder where you have write permissions, not checking 'Open as read-only', etc - files should also have the 'Read-only' attribute cleared in the filesystem. If a particular file has the 'Read-only attribute' set, then the data source will not show the lock icon (so, not like in your case), but the data will still be read-only, tables will be gray, menu commands will be disabled, etc.

hsamuel16 post(s)
#18-May-18 12:11

The issue is, I was okayed to install Manifold Viewer because it's free install. Is Manifold 9 or any version of it, free to install?

adamw


7,903 post(s)
#18-May-18 12:22

No, 9 is not free.

You can create components in Viewer, just in the opened MAP file, not in the linked data sources.

Dimitri


4,843 post(s)
#18-May-18 14:10

Look at the pictures below. Click on a picture to make it bigger.

That's Viewer running, linking in the books.mdb sample file from the Fehily book on SQL. (It's an mdb so you have to launch Viewer from the 32-bit Bin folder. Don't need to worry about that if you're working with a dbf).

You can right click into the project outside of the read only data source and choose Create - New Query.

Double-click the new query you create to open it in a command window. Now you can drag and drop the authors table from the mdb into the lower right pane of the query builder. That will show you the fields and how to refer to a table inside the data source.

You can write a query and run it with the ! command. The results table will be read-only because you are querying a read-only database.

You can write what you want into the main part of the project pane. If you change the query so it is a SELECT ... INTO you can write the results into a table that is outside the read-only data source. You can do with that table whatever you want.

Attachments:
readonly01.png
readonly02.png
readonly03.png
readonly04.png

Manifold User Community Use Agreement Copyright (C) 2007-2017 Manifold Software Limited. All rights reserved.