Subscribe to this thread
Home - General / All posts - ODBC connection to M9
apo53 post(s)
#21-Jun-18 09:11

Using the M9 9.0.167.4 under W10, I'm facing troubles setting a new System DSN to connect to M9. Creating the same for M8 works like a charm by doing this for M9 failed retrieving the dialog. Doing a File DSN also failed (the file is created but all connection mentioned a corrupted one. Does has this to do with the name of the Driver (length, special chars, ???).

Did anybody succeed in this ?

Any helpwould be appreciated, Thanks

Dimitri

5,119 post(s)
#21-Jun-18 11:35

What happens when you apply the procedure in the Example: Create an ODBC Data Source with Windows topic? If you try to reproduce that step by step, in which step does it go wrong?

apo53 post(s)
#21-Jun-18 15:22

running the odbc administrator tool as administrator in the add I can see the Manifold 9.0 Project Driver (*map) in the list, but not its experimental version

Then selecting the Driver and clicking finish does not launch a dialog raised by the Manifold ODBC driver. but just do nothing.

Selecting the Manifold Project Driver (*.map) is just fine

adamw


8,259 post(s)
#21-Jun-18 16:47

You have to register the driver in the portable install to use it (then unregister when you are removing the portable install or switching to a newer version of it for which you want to use the ODBC driver).

See the instructions in INSTALLATION.TXT in the root folder of the portable install (basically, you have to run 'manifold -install' from the command prompt with Admin privileges).

What was the build of the non-portable version of 9 the driver of which failed to display the dialog? You should see the build number in the list of drivers.

apo53 post(s)
#21-Jun-18 20:20

Thanks Adam for the procedure but this one was done prior to the test of connection. As seen in the attached image one M9 driver is available in its latest version. Testing several other ways to connect I tried the dsn file one. This is producing something interesting referring to the (experimental) version which name is not available in the list of drivers. Doing this is displaying the following params in the administration tool

File Data Source

Filename: C:\Users\abram\Desktop\test.dsn

Driver: Manifold 9.0 Project Driver (*.map)

but this in the created dsn file

[ODBC]

DRIVER=Manifold 9.0 Project Driver (Experimental) (*.map)

DBQ=C:\test.map

connecting using this dsn file ends on the error described in the file

Attachments:
odbcadmin.png
odbcerror.png

adamw


8,259 post(s)
#25-Jun-18 14:39

The first screen (ODBCADMIN.PNG) is strange in that it shows EXT.DLL from a cutting edge build (167.4) registered with the name of a public build (167.0 or a similar prior build).

Attempting to use the driver configured in this way cannot succeed because what's in the DLL and what's in the registry does not match.

I just tried registering the ODBC driver for 167.4 on a test system and it registered with the correct name (Manifold 9.0 Project Driver (Experimental) ...).

How did it end up like this? Could it be that you ran MANIFOLD.EXE -INSTALL on a public build and then later replaced the contents of the folder with a cutting edge build? To fix it, download the portable install of a public build of 9, put it into the folder from which the driver is registered (you can find it in the registry: HKLM \ SOFTWARE \ ODBC \ ODBCINST.INI \ (driver) for the 64-bit version and HKLM \ SOFTWARE \ WOW6432Node \ ODBC \ ODBCINST.INI \ (driver) for the 32-bit version), then run MANIFOLD.EXE -UNINSTALL to remove the driver. After that, verify that the system no longer lists the driver in the ODBC dialogs, then install the driver for the build you want to use. You can have drivers from a single public build and a single cutting edge build installed simultaneously, the EXE / MSI install packages for public builds automatically install and uninstall their drivers.

Hope this helps.

Manifold User Community Use Agreement Copyright (C) 2007-2017 Manifold Software Limited. All rights reserved.