Subscribe to this thread
Home - General / All posts - Convert Table with geom to Drawing in Radian
surveyor
27 post(s)
#21-Oct-18 02:13

So I was about 2% in learning M8, so I thought I would finally make the jump to Radian. (Or is it called M9 in this forum?). It is painful, but like going to the gym it's a good pain. But like all learning activities, sometimes even simple things can be frustrating. Or maybe they are particularly frustrating because they are simple, yet cause a roadblock. Today's example: Creating a drawing form a table.

  1. Table started as a CSV file which I imported. One column is "NORTH" and the other is "EAST".
  2. I added a column called mfd_id and created an index on it.
  3. Following the example in the manual,Example: Create a Drawing from a Geocoded Table, I populated the Geom field with points so the Geom column is full of <geom, point>
  4. Right-Clicked on the table and chose "New Drawing". But instead of getting the dialog box shown in the example mentioned above, I get the generic dialog box for creating a drawing from scratch.

The frustrating thing is... I did this before and it worked. No idea what I am doing differently. At first I thought my geometry had to be 2d (I also have a Height value so used the "withZ" option to create 3d points, but then added a new Geometry column with 2d points) and it makes no difference.

I ran a query on the table to check the geometry which gives expected results.

SELECT GeomWkt(Geom) FROM [BoundaryPointsFromL]

Any idea what I am doing wrong?

"Learning is such an endless affair. I'd stop you if I could, but then again, I wouldn't dare."

Dimitri

5,082 post(s)
#21-Oct-18 10:52

I thought I would finally make the jump to Radian. (Or is it called M9 in this forum?)

Radian Studio and Release 9 are two different products. See the 9 FAQ.

In this forum, people normally call Release 9 either "9" or "M9" or whatever. They refer to Radian Studio as "Radian Studio." "Radian" these days is mainly used to refer to the internal parallel database technology on which Radian Studio, Release 9, and all other modern Manifold products are based.

Any idea what I am doing wrong?

Assuming you are using the latest build of Release 9 and not Radian, (always say what you are using to avoid making everybody else guess...), you've probably missed some simple detail, like not right-clicking on the table but instead just right-clicking on a blank portion of the project. Or, you missed some simple detail when you created geometry.

However the New Drawing dialog opens up, you can always choose an existing table on which the drawing will be based by choosing the desired table in the Based on box. If you don't see in the list offered the table you believe you populated with geometry, that means there was a mistake made further back.

You can give yourself the confidence that creating a new drawing from an existing table works perfectly every time by opening one of the example projects that can be downloaded, right clicking on a table for a drawing and creating a new drawing using that table.

See also the New Drawing help topic.

Manifold User Community Use Agreement Copyright (C) 2007-2017 Manifold Software Limited. All rights reserved.