Subscribe to this thread
Home - General / All posts - M9 can't open M8 Project
rhowitt51 post(s)
#26-Nov-18 16:25

We have tried opening our M8 projects using M9 and have not been able to open any of our projects.

the project starts to load, a window showing the count of layers a that are being loaded is displayed and then before it finished the message "Can't Load Data" is displayed. The load is aborted and Manifold is left with a blank project.

We want to start using M9 but can't until we can open our M8 projects.

We can send you an M8 project if needed.

ColinD


1,886 post(s)
#26-Nov-18 19:19

More info needed. What version of M9? What is the content of the M8 projects, are there a lot of links to databases and if so what type are they? Any of my M8 projects that I have tried will open in M9.


Aussie Nature Shots

tjhb

8,410 post(s)
#26-Nov-18 19:45

To add to Colin’s comments:

Also important to know if it is a full install of M9, or an unzipped cutting edge build.

Plus, what happens if you make a new blank M8 project, add one Comments component, save it, then try opening it in 9?

rhowitt51 post(s)
#26-Nov-18 20:05

The buld is 9.0.168.4 for M9, unzipped cutting edge.

The project is a template that we use to create new projects. When loading the project Manifold says it is loading 317 objects.

The template consists of :

1) Many Map definitions,

2 ) many local drawings

3) Many prefined local SQL queries

4) Many VBScripts

5) many Layouts

6) many images

7) a couple of links to MS SQL server

Going through this list , I can see that there will be issues with VBScripts, SQL scripts and connections to the MS SQL Server.

We have something like 300 M8 project files. If we have to recreate all 300 projects from scratch that will be a large impediment to moving forward with M9.

tjhb

8,410 post(s)
#26-Nov-18 21:04

All of 3 and 4 will need rewriting (though simple SQL can often be adapted fairly quickly, if not optimised).

Layouts are coming—and perhaps there will be partial automatic translation from 8.

For now though, I would take Colin’s strong hint, and try making two copies of the template to help isolate the issue: one with items 1 to 6 without 7, one with item 7 only.

ColinD


1,886 post(s)
#27-Nov-18 03:04

It sounds possible that 1 to 6 all draw on 7 and for some reason MS SQL server is not linking. Otherwise at least the queries and scripts would load.


Aussie Nature Shots

rhowitt51 post(s)
#28-Nov-18 15:44

I have unlinked the one table that is linked to an Ms SQL table, but the load is still aborting. I will continue to remove objects until I get a good load. This is going to be slow.

Does M9 produce a log file of any kind that might show which object is causing the load to abort?

tjhb

8,410 post(s)
#28-Nov-18 16:05

There is a log file written to disk, yes, though I'm not certain that it will contain exactly this info. (I'd be interested to know.)

For the file location, see the subsection Logging Files under the Log Window topic.

rhowitt51 post(s)
#28-Nov-18 22:00

Thanks.

Just tried it.

It does not log the offending object that causes the load to fail.

tjhb

8,410 post(s)
#28-Nov-18 23:11

Thanks for coming back, sorry it wasn't more help.

It would make a nice feature request? Optional verbose logging on opening Manifold 8 projects.

Manifold User Community Use Agreement Copyright (C) 2007-2017 Manifold Software Limited. All rights reserved.