Subscribe to this thread
Home - General / All posts - Manifold Install Issue
364 post(s)
#07-Jan-19 23:16

Hi folks - it's been a long time.

I'm trying to install Manifold after reinstalling windows. The install would not automatically grab the activation key, so, I tried manual activation but the link ( doesn't work. I also tried to check the status of my serial number, but again the link doesn't work.

Any pointers?

Also, what is the highest current version of PostgreSQL/PostGIS supported by Manifold 8?




8,743 post(s)
#08-Jan-19 06:47

Today is [early on the day after] Christmas Day in Russia.

Wait one day for the servers to be revived.


8,568 post(s)
#08-Jan-19 12:32

We've been working since January 2. :-) (Not everyone, because many people take several extra days off for the winter holidays here, but enough to move the code forward sensibly.)

By the way, this reminds me of Spectre and related vulnerabilities - they were big news the previous holidays. Last we talked about that it was up to the compilers and tools to detect and patch code. Well, things progressed from there and we now had the required support from the compilers for some time. Long and short, the issue seems to be much less terrible than it appeared at first.

The very first thing we did when we got compilers that could detect and fix the vulnerability reliably was look at just what places in our code are affected and how many of them there are. As it turns out, (a) there are not that many - a couple of hundred hits out of a couple of million lines of code, and (b) all of them very far from any input. For (b), it is quite hard to imagine what the malicious user can even do to try and hit a place in code that is theoretically vulnerable, yet alone keep hitting that place with predictable speed, yet alone at any reasonable rate (to recap, the vulnerability, very roughly, is that an external observer can see how fast the code runs and can reason out some of the internal state by varying input and looking at how the performance changes). If anyone were to try to hack into our code, it would have been much simpler to just use a doctored version of GDAL or something else that allows using small user DLLs.

So, we took a conservative approach and have been simply rewriting code that can theoretically be exploited using Spectre so that it can no longer be exploited that way even theoretically. Because the number of places which are affected is not big and not growing, only reducing (we track the number of such places and the new code is not allowed to introduce any new places to fix).

One scare less.


8,743 post(s)
#10-Jan-19 22:17

I missed this post at first--sometimes the eyes assume that latest=only new.

Very interesting Adam, thank you.


5,436 post(s)
#08-Jan-19 08:34

Ummm... is in Hong Kong. Christmas in Hong Kong is 25 Dec. :-) Servers are up and running fine, with multiple activation servers around the world.

Sounds like you didn't enter the link correctly:

It's and not http://

See links/comments in the Troubleshooting page.

I also checked serial number status (worked fine) using the link in the Support page. To avoid typos, it's a good idea to click on the published links.

By the way, if something in your network setup or computer system is preventing Manifold from automatically fetching an activation key, it's a good idea to get that identified and fixed. Why not take advantage of automatic function instead of hassling with doing things manually?


8,743 post(s)
#08-Jan-19 08:55

Ooops, but...

It is strange and unhelpful for URL direction to depend on the protocol specification.

http://x should go to the same place as https://x, or should give a meaningful message (regarding security) why it does not.


8,568 post(s)
#08-Jan-19 12:12

We agree.

The web team fixed the redirection logic, it should work fine now (navigating to a page inside the domain using http should automatically switch to https).

364 post(s)
#08-Jan-19 09:37

Hi Dimitri. Hope you're well, and HNY etc...

I have uninstalled and reinstalled Manifold, but still no joy. I paid attention to ensuring I had administrator privileges, turning off AV and firewall, but still no joy.

I'm not sure if it's related, but I have also tried those links again. Using Chrome, if I reset it to default settings and try to follow the link to Manual Activation or Serial Number Status I get a a certificate warning - see attached screenshot. Neither certificate is accepted and from then on, no warning, the link just doesn't work. I've also tried using Edge and IE, but still no joy.

Any help appreciated.

Regards O


308 post(s)
#08-Jan-19 09:42

When Manifold store etc. is asking for certificate, then press Cancel.


8,568 post(s)
#08-Jan-19 12:13

This is now fixed as well.

The endpoint that was using client certificates moved elsewhere. No more having to cancel.

Thanks for the note, it allowed us to fix the oversight.


5,436 post(s)
#08-Jan-19 11:31

I'd guess something at your end. I've just tried Chrome, Edge, IE, and Opera with no issues. No doubt there's a web page where somebody who knows browser configuration could offer good advice. I'd just guess at things like any sort of "security" add-ins, etc.

364 post(s)
#09-Jan-19 20:00

Hi again.

So an update:

- The website certificate issue is now fixed (at your end I believe).

- I could not find the issue preventing automatic activation, and manually activated Manifold successfully.

- Radian activated automatically, so it seems this issue also was not at my end?

But whatever, all now sorted, for me at least.



364 post(s)
#10-Jan-19 18:53

And now another issue.

I am installing manifold to my laptop - as I believe I am entitled under the license. But when I get the activation code (automatically) and then press activate, I get a message stating activation key is not valid! I do not understand.

Any pointers


jsperr60 post(s)
#10-Jan-19 19:42

Check the activation documentation -- I seem to remember there is a 24 hour freeze on successive activations.


5,436 post(s)
#11-Jan-19 07:59

I seem to remember there is a 24 hour freeze on successive activations.

The same serial number yields the same activation key for 24 hours. See the discussion in the activation topics.


5,436 post(s)
#11-Jan-19 08:19

Any pointers

Yes. Visit the Activation Troubleshooting page. It's always one of the Simple Errors in that short list. [Example: Getting the same key for 24 hours is in the list.]

If that does not help, the forum rules do not allow discussion of activation (note the use of the word "any"):

No discussions involving copy protection.- To ensure participants attempting to pirate software from any company are not assisted this site does not allow anyone to engage in any discussion or to provide advice or opinions on copy protection mechanisms, such as activation, used by any company.

That's not a bad policy, since there's no way you can post to the forum all the confidential info required (serial number, activation key, system ID, etc.) to systematically review all of the Simple Errors to find the one that's causing the problem. In contrast, you can provide all info to Tech Support and they'll solve the problem instantly.

If a super-attentive review of the Troubleshooting page doesn't solve the problem immediately, the next move is to get free Activation Support from Tech support. Follow the instructions in that page and Support will identify the error and will solve the problem instantly for you, no support token required.

Usually what happens, by the way, is that in the process of putting together the necessary info it becomes obvious what the error is (wrong SN, wrong install file, system date wrong, etc.).

Above all, don't waste time posting to the forum here if you already have fetched an Activation key. Doing that just burns up the 72 hour life of the Activation key that you have to identify the problem. Immediately use the free Activation Support process and make sure to send all of the required info, etc.

Manifold User Community Use Agreement Copyright (C) 2007-2017 Manifold Software Limited. All rights reserved.