Subscribe to this thread
Home - General / All posts - Image Manifold web server not responding
samuelgj18 post(s)
#06-Jan-20 17:08

Since today I cant connect to the manifold web image server, any idea hoy to connect to?

Dimitri


5,695 post(s)
#06-Jan-20 18:08

Looks like those sites are off line. I can't reach them either. Probably some network configuration issue - there have been many infrastructure upgrades at manifold recently.

samuelgj18 post(s)
#06-Jan-20 21:18

Thankyou for your answer!

Do you know, Where o with whom can I get an actualization of the openstreet maps dll?

Dimitri


5,695 post(s)
#07-Jan-20 05:57

Ah, I think I misunderstood your original question. It seems you were asking about imageserver modules, not about example web sites using Manifold Release 8 IMS (see here).

Are you working with Release 8 or Release 9?

For Release 8 imageserver modules, see the Image Servers page.

For Release 9, an OSM imageserver module is built into Release 9 and Viewer. See the Web Servers topic and the topics it recommends.

Dimitri


5,695 post(s)
#07-Jan-20 06:39

Looks like those sites are off line.

They're back up. Visit the IMS examples page and all the sites seem to be working. Fast, too! :-)

samuelgj18 post(s)
#07-Jan-20 19:29

The openstreet server is not responding, also many others. Thats why I think the dll are not updated

Attachments:
cloudmade.PNG
nearmap.PNG
openstreet1.PNG
yahoo.PNG

samuelgj18 post(s)
#07-Jan-20 20:15

By the way I use Manifold v8.0.30.0

Sloots

451 post(s)
#08-Jan-20 14:50

Osm server responds with error. Changed the extension to..de instead of. org using the custom url. That works fine for now...


http://www.mppng.nl/manifold/pointlabeler

samuelgj18 post(s)
#15-Jan-20 20:46

This was the solution for me! thanks a lot!

Dimitri


5,695 post(s)
#08-Jan-20 05:48

The openstreet server is not responding, also many others

I think you may be confusing two different things: an image server module is not the same as a Manifold IMS web site.

If you try to connect to an image server and cannot connect, that just means the server operator no longer supports the URL that is used. Check the "Use custom server URL" box and enter a current URL.

Or, if you don't want to do that, use one of the servers that still supports the URL that is compiled by default into the imageserver module you are using. Virtual Earth, for example.

Free servers hosted by third parties often change. I prefer to use Release 9 because that provides a much wider choice of servers that use more recent technology, and it's much easier to use.

Hatt7 post(s)
#11-Jan-20 17:01

Same problem: two machines both 8.0.30.0 running 64 bit: (1st machine) M8 installed last year, used Manifold IMS often, now can't connect to server; (2nd machine) new, just installed M8, downloaded allserverspak.zip, unzipped dll's to Manifold System folders in both Program files and Program files (x86), get message "No Manifold image servers installed". Any ideas most appreciated.

tjhb
9,045 post(s)
#11-Jan-20 19:09

I have no suggestions about the 1st machine, but for the 2nd machine, ensure that the downloaded .zip archive is unblocked (right-click the .zip file -> Properties -> Unblock) before you copy its contents to the destination folder(s).

Since you have already copied the contents over, if you did not unblock the source archive first, you will have to delete the existing .dll files and start again.

Hatt7 post(s)
#11-Jan-20 21:35

Thanks for quick response. Zip file was already unblocked, but deleted and repeated unzipping contents after confirming unblocked, still no access. I should have mentioned. this is new HP PC Win 10 Pro, Windows Defender. Surface tools also installed. Have rebooted several times and reinstalled M8.

adamw


8,842 post(s)
#12-Jan-20 08:33

"No Manifold image servers installed" means that the image server DLLs fail to load - things don't even get to the server.

Could you check if these specific DLLs exist and are unblocked (the Properties dialog for the file in Windows Explorer should not have the "Unblock file ..." option on the first page):

Manifold.ImageServer.dll

Manifold.ImageServer.ManifoldIMS.dll (this is the default image server that connects to a Manifold IMS site, it is always there)

...and one of the image server DLLs from ALLSERVERSPAK.ZIP that you want to use.

If one or more DLLs are blocked, unblock them, then restart Manifold and repeat. If this will still fail, check if the DLLs are blocked again - if they are, the unblocking failed, this has to be fixed.

If one or more DLLs are missing, this might be related to an antivirus or a similar monitoring tool. This has to be fixed as well. Try using 64-bit modules in the meantime, most of the antivirus tools with questionable blocks only concern themselves with 32-bit code and leave 64-bit code alone.

If the DLLs are there and are unblocked but they still won't load, check (a) realtime antivirus protection - turn it off for a moment, then restart Manifold and see if this will fix things, and (b) Windows updates - are all updates to .NET 4 installed? If you launch 8, create a new C# script, does it run without errors?

adamw


8,842 post(s)
#12-Jan-20 08:46

(One more thing: in general, try Viewer. It's free. The configuration issues with image servers in 8 can be sorted out, but Viewer uses more modern URLs and frequently newer web APIs, it plain has more servers to choose from, it is faster, etc.)

Hatt7 post(s)
#12-Jan-20 15:36

thank you both for quick responses. I performed as follows:

a) checked dll's as listed by Dmitri for being blocked - interestingly, Manifold.ImageServer.dll and Manifold.ImageServer.ManifoldIMS.dll don't have block/unblock box (which I understand means they are not blocked). Manifold.ImageServer.VirtualEarth.dll did have a block box but it was unchecked, so not blocked. Restarted machine, turned off virus protection (Windows Defender including firewall), confirmed .Net4 is installed (this is on the new machine with Win 10 Pro) and started Manifold 8.0.30.0 64 bit. When I tried file/ link/image/Manifold Image Servers () I get same message of "No Manifold Image Servers Installed". so, no change.

b) following adamw's suggestion, i downloaded and installed Viewer 9.0 64 bit. Tried file/create/new data source/bing maps satellite and it loaded. double clicked on it and it appears and I zoomed in to street level, works fine.

c) since Viewer working, started M 8.0.30.0, both immediately and after restarting, same "No Manifold Image Servers Installed". so, no change.

given Viewer works, would appear the problem may be with the dlls downloaded with the allserverspak.zip. if Viewer employs "more modern URLs and frequently newer web APIs" would somehown copying these to the Program Files/Manifold System (and x86 sister) folders work? However, the Viewer folders don't seem to have comparable dlls.

Any assistance most appreciated.

Dimitri


5,695 post(s)
#12-Jan-20 15:59

Such issues almost always boil down to permissions problems, or other configuration issues like not having the image server .dlls where they are supposed to be. You need full and total details to track down what is wrong.

The suggestion to use Viewer I think was simply that if you want to look at something using a web server you can just use Viewer, since that functionality is built into Viewer and does not rely on using .dlls that must be downloaded and installed.

If you want to track down what's preventing image servers .dlls from being found by release 8, you have to look at every small detail that in a Windows operating system might prevent a .dll from being launched.

One of those things is how Windows may prevent .dlls from running ("blocked") that you've downloaded from the web. For added fun, it doesn't tell you that it has done that. So you have to go through the fire drill of unblocking them. For extra added fun, in some situations you might use a dialog that appears to unblock a file but then Windows doesn't actually unblock it. Get it wrong, and Windows still prevents the dlls from running. There are lots of web pages that discuss such Windows issues.

Another thing that may prevent .dlls from running are ordinary permissions, like the login you're using not having read or run permissions. Usually you can check that by simply logging in as *THE* Administrator (not using a login that you believe to have Administrator privileges, but logging in as the Administrator) and then launching. If the .dlls are recognized, then you know it's a permissions issue having to do with the login you were using.

That's the simple stuff. More complex are various Windows security policies that can be set that might interfere with a .dll being allowed to run, etc. If anybody else has any sort of control over your machine (a helpful IT department? ) they might have changed policies. Default setups almost always work, but changes to default Windows settings can be very difficult to decipher.

You just have to be patient and go at it one possibility at a time, being careful to check all details.

tjhb
9,045 post(s)
#12-Jan-20 23:55

Yes.

I still think it is worth revisiting the unblocking question.

The ~bulletproof way to do this is like this:

  • Delete any existing image server .dlls.
  • Delete any previously downloaded .zip archive.
  • Download a fresh copy of the image servers .zip archive, directly to a folder where you have full write permissions, such as your own user desktop.
  • Without moving the .zip archive, right-click it, and choose Unblock.
  • Now open the archive, Copy the required .dlls, navigate to the destination folder, and Paste.

Exactly that.

djmcbell26 post(s)
#13-Jan-20 00:33

I'm having a slightly different error, and one which is probably just something simple I'm overlooking.

I'm trying to use the Manifold Image Servers, however whenever I try to add one I just get a blank image. Even if I try to add one that was previously set up and works okay (and, when I go into the properties, has the exact same properties as the one that works).

I've downloaded the dlls (unblocked etc, just as described). This is for Manifold 8 on a 64-bit Win 10 machine. My replication steps are:

* in Manifold, go to File > Link > Images

* then browse for Manifold Image Servers()

* select the service I want (in this case it was Bing, at http://ecn.t*.tiles.virtualearth.net/tiles/ - which does work in a file created before I started in this role)

* choose "global" (already selected) and refresh to ensure it is there. No issues, map size appears

* choose ok. Mapnik is created

From there, if I double-click the mapnik itself, all I get is the standard transparent "checkerboard". This also won't appear on a map if I add it (drag and drop to map), or if I create a new map from it (right-click, create - map). The original one, which does work, works fine in this.

I'm essentially trying to get the OpenStreet Map working, using the .de address, in the end, but practicing using something that should work.

djmcbell26 post(s)
#13-Jan-20 01:53

Got it - when adding, I had to take off the "Cache data between sessions" option.

Dimitri


5,695 post(s)
#13-Jan-20 05:08

I'm glad that worked out, but your post points out how details are important. Specifically, something is wrong in these details:

select the service I want (in this case it was Bing, at http://ecn.t*.tiles.virtualearth.net/tiles/

and

choose ok. Mapnik is created

But "Mapnik" is not Bing at Virtual Earth.

When reporting what is being done so folks here in the forum can offer tips, it is important to try to report all details precisely. You've got your installation going, so no worries for now, but it's good to keep that in mind in case of any future issues.

Hatt7 post(s)
#13-Jan-20 13:14

reinstalled M 8.0.30.0 and then per tjhb advice, did exactly that:

  • Delete any existing image server .dlls.
  • Delete any previously downloaded .zip archive.
  • Download a fresh copy of the image servers .zip archive, directly to a folder where you have full write permissions, such as your own user desktop. (downloaded to desktop)
  • Without moving the .zip archive, right-click it, and choose Unblock. (was unblocked)
  • Now open the archive, Copy the required .dlls, navigate to the destination folder, and Paste. (pasted to Manifold System folder in both Program Files and Program Files (x86)

still getting "no Manifold image servers installed". Tried TerraServer, which just churned.

per Dmitri's advice, have spent considerable time reviewing permissions and control - both All Application Packages and me as Users have Full Control over the folder (although the folder is read-only, can't seem to remove that). No one else has access to machine (ie, no IT geek, it is my machine, new HP PC right out of box).

Turned Windows Defender off, specifically allowed Manifold app permission to communicate thru firewall.

problem persists. any ideas most welcome.

Dimitri


5,695 post(s)
#13-Jan-20 17:36

1.Did you unzip the archive with .dlls?

2. Did you try logging in as *THE* Administrator?

3. Is Release 8 installed in the usual, default C: path? Or is it installed somewhere else, on a USB drive, etc?

Hatt7 post(s)
#13-Jan-20 20:05

1. opened the zip file and cut and pasted dlls into c:\Program Files\Manifold System, and similar for Program Files (x86), per tjhb.

2. yes - note installing M 8.0.30.0 requires logging in as THE Admin'r, and I did that to install. Similarly, cut and pasted dlls while logged in as TA, and tried to run while so logged in.

3. installed where the installation file put it, cited in 1. above.

really appreciate your continued efforts to assist, most kind.

Hatt7 post(s)
#13-Jan-20 20:17

attached are screenshots of the M8 folder with dlls, and also the result.

Attachments:
folder contents.jpg
result.jpg

Dimitri


5,695 post(s)
#14-Jan-20 08:23

Do you have any security software of *any* kind running? I don't mean Windows Defender, I mean anything like a registry protector or other security system?

If you log in as THE Administrator and navigate to the installation folder, and then you right-click on the .dll for virtual earth, what, exactly are the permissions on that file? Is it unblocked?

adamw


8,842 post(s)
#14-Jan-20 13:01

a) checked dll's as listed by Dmitri for being blocked - interestingly, Manifold.ImageServer.dll and Manifold.ImageServer.ManifoldIMS.dll don't have block/unblock box (which I understand means they are not blocked). Manifold.ImageServer.VirtualEarth.dll did have a block box but it was unchecked, so not blocked.

Something seems wrong here.

Here's the screen of the Properties dialog that I get from saving one of the attachments up the thread in the default Windows configuration:

The checkbox is unchecked, but its text is Unblock. You have to check this checkbox and then click Apply or OK to unblock the file. After you do this, the checkbox will disappear.

The mere presence of the checkbox means that the file is blocked. Unblocked files do not show the checkbox.

If you inspect Properties for your DLLs, do you see the same checkbox or do you see something else? If you see the same checkbox, check it, click OK, then restart Manifold 8 and see if you can now use Manifold Image Servers in the now-unblocked DLL. If you see something else, make a screenshot and post it here.

Sorry for the hassle, this blocking / unblocking business can be really annoying. (By the way, there is a group policy to turn it off, but we are prohibited from using it on development machines, because then we won't see issues that our users see. :-))

PS: Also, Viewer does not use these DLLs, it uses different code embedded into it. For one thing, this avoids this annoyance with DLLs sometimes refusing to load due to configuration issues.

Attachments:
block-unblock.png

tjhb
9,045 post(s)
#14-Jan-20 17:36

Apart from the Group Policy setting, and its equivalent registry patch, there's a Windows Powershell script to unblock all files in a folder tree previously posted here.

I run the script over all drives from time to time to clean up anything that sneaks through.

Hatt7 post(s)
#18-Jan-20 19:37

THANKS TO EVERYONE, PROBLEM SOLVED. Boy, I really feel stupid. Dmitri was correct, of course, it was a permissions thing. But adamw caught it - one has to check the UNBLOCK box to unblock, sort of a double negative, but i suppose logically correct. checked all dll unblocks and now can link.

really appreciate support, and am chagrined over such an obvious - must learn to read better.

with best regards and sincere thanks to everyone.

dchall8
681 post(s)
#19-Jan-20 18:26

No need to feel bad, this is not a common sense sort of thing. You'll never have to unblock a .dll in any other program. If you search this forum for "unblock", you'll see it is an old issue we've all seen before.

Dimitri


5,695 post(s)
#20-Jan-20 11:47

You'll never have to unblock a .dll in any other program.

? Sure you will, if the program uses .dlls downloaded from the web. The block / unblock thing is a Windows security feature that impacts every program which can use .dlls downloaded from the web.

Manifold User Community Use Agreement Copyright (C) 2007-2019 Manifold Software Limited. All rights reserved.