Subscribe to this thread
Home - General / All posts - Linking ACCDB
joebocop
442 post(s)
#14-Jan-21 16:59

I'm not able to link to ACCDB files using Release 9; perhaps I'm doing something obviously wrong.

I am running 64 bit Manifold Release 9.0.173 on Windows 10 20H2. I have Microsoft Office 365 installed, whose Access "About" dialog shows "Microsoft (R) Access (R) For Microsoft 365 MSO (16.0.13530.20368) 64-bit".

Any attempt to install the 64-bit Access Database Engine fails with the error "Another version of this product is already installed (...)".

When I "link" an accdb file and then click the "+" sign on that Data Source component, the Release 9 Log pane shows no errors, and reads back "2021-01-14 09:51:43 -- (root)::[my_db.accdb] Connected using ACE16." No table components (other than mfd_meta and mfd_root within the System folder) are displayed beneath the expanded Data Source component.

If instead of using "File --> Link" I use "File --> Import" and specify the same accdb file, the one table within the accdb file imports correctly (albeit with the columns arranged in mostly alphabetical order rather than the order configured on the table in the accdb file) into the Manifold project.

Instructions provided at (Microsoft Office Formats - MDB, XLS and Friends (manifold.net)) indicate that if "File-->Link" does not work as documented, that there is something wrong with my installed Microsoft facilities that would enable this functionality. The fact that I'm able to import makes me think the problem may lie elsewhere.

Any thoughts? Thank you, in advance. I hate this.

Dimitri


6,437 post(s)
online
#14-Jan-21 17:45

Just re-read the topic, looking for tips, and man, does it hit the nail on the head when it says "There is no sugar-coating it: installation of 64-bit Access Database Engine can be an inconvenient mess. "

I saw this in the topic:

"Launch Manifold in 64-bit mode and use File - Linkto try linking an .xlsxor .accdbfile. If we can link an .xlsxor a .accdbfile, that means we have 64-bit Access Database Engine installed. Done! If that does not work, launch Manifold in 32-bit mode and again use File - Linkto try linking an .xlsxor .accdbfile. If that works, we have 32-bit Access Database Engine installed. "

What happens when you launch Manifold in 32-bit mode, and try to link?

Also, it's strange that you can import, but the link does not show data. Could it be that the file is in use? Try rebooting, don't launch Office 365, and try linking, both from a 64-bit Manifold session and then from a 32-bit Manifold session.

Those are just wild guesses. I'll ask around if anybody with experience with the access database engine could offer some real insights.

joebocop
442 post(s)
#14-Jan-21 18:30

Thank you Dimitri. I had also tried launching Release 9 in 32-bit, and both linking and import fail with log pane messages:

*** (root)::[my_db] Provider=Microsoft.Jet.OLEDB.4.0;... SQLSTATE: 3343. Unrecognized database format 'C:\Users\joe\Downloads\my_db.accdb'.

*** (root)::[my_db] Provider=MSDASQL.1;... SQLSTATE: IM002. [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

*** (root)::[my_db] Provider=MSDASQL.1;... SQLSTATE: 01000. [Microsoft][ODBC Microsoft Access Driver]General Warning Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x5b2c Thread 0x3370 DBC 0x70e228c Jet'.

*** (root)::[my_db] SQLSTATE: 01000. [Microsoft][ODBC Microsoft Access Driver]General Warning Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x5b2c Thread 0x3370 DBC 0x70e228c Jet'.

*** (root)::[my_db] SQLSTATE: S1000. [Microsoft][ODBC Microsoft Access Driver] Cannot open database '(unknown)'. It may not be a database that your application recognizes, or the file may be corrupt.

*** (root)::[my_db] Failed to connect (tried ACE16, ACE15, ACE14, ACE12, Jet4, Jet3.51, MSDASQL.1).

For fun, I launched Release 8 64-bit (same computer), and both import and link work correctly, with the columns from the accdb file in correct order in the corresponding Manifold table components.

The same behaviour is true for an XLSX file I just tested with Release 9 64-bit: link "fails" (but with no log errors), and import works, but the Manifold table components' columns are reordered alphabetically.

joebocop
442 post(s)
#18-Jan-21 17:08

This feels like a "bug", and I'd be happy to submit, though confirmation of this behaviour from one additional user would be helpful.

Is anyone able to successfully "Link" and ACCDB file in 9.0.173, Windows 10 20H2, with Office 365 x64 installed? A long list of caveats, I know. Thanks.

Manifold User Community Use Agreement Copyright (C) 2007-2019 Manifold Software Limited. All rights reserved.