Subscribe to this thread
Home - General / All posts - Shift + Esc stops working
Mike Pelletier


1,859 post(s)
#06-Apr-21 00:03

Was wondering if anyone else has troubles with Shift + Esc not working in 9 for returning to the Default cursor. This occurs on my desktop but not my laptop. The only thing that seems to help is reinstalling keyboard driver, but it doesn't last and haven't found a pattern of what triggers it to stop working. New keyboard didn't help.

tjhb

9,627 post(s)
#06-Apr-21 00:16

Obvious question: why do you have a keyboard driver? Nobody needs a keyboard driver with Windows. The built-in driver is just fine.

What functions does the custom driver provide, that you really need?

Can it be cleanly removed?

Mike Pelletier


1,859 post(s)
#06-Apr-21 02:28

It is the built in driver that I'm talking about.

No idea what makes it stop working. Last time just opened the program, 3rd time I think, and it wasn't working.

tjhb

9,627 post(s)
#06-Apr-21 03:34

Oh, right.

For what keyboard then.

oeaulong

309 post(s)
#06-Apr-21 00:36

Can you reproduce this? I have seen similar behavior, but cannot seem to duplicate.

adamw


9,552 post(s)
#06-Apr-21 14:38

Does the map window have the focus? If you are unsure, click the window tab (above the data), this will move the focus to the window.

If this was the culprit, tell us what specifically you did to lose the focus. Obviously, you expected the map window to have it and the window didn't have it. My guess is that the window had it, but then you ran some command or something and the focus was lost. We did hear about this happening, found one scenario and fixed it, but there are perhaps others. We need to know what they are to try and fix them.

Also, perhaps we need to indicate which tab has the focus somehow.

Mike Pelletier


1,859 post(s)
#06-Apr-21 15:05

Not window focus. My steps are open new project. Open new Drawing. Start drawing with area, line, or point tool. Hit Shift + Esc and nothing happens. Same thing on my home HP laptop. On a Surface Pro laptop, these steps return to the default cursor.

This odd behavior isn't new and actually thought it was an obvious enough issue that it would get fixed. Just finally decided to look into it. Seems like it is something unique to my computer's setup, but extra odd it is both my computers.

Using a Logitech keyboard and it works fine on the Surface Pro.

rk
433 post(s)
#06-Apr-21 15:17

Could it be the Fn modifier? On my keyboard (Dell KB216t) Fn-Esc means Fn-Lock. Shift-Esc works always though.

Mike Pelletier


1,859 post(s)
#06-Apr-21 15:35

Hmm. No Fn key on my Logitech keyboard. However, I did find that using the Windows key + Shift + Esc works. Thanks for the tip! I'll send a note to Tech.

adamw


9,552 post(s)
#06-Apr-21 15:48

I found a strange article which implies that Shift-Escape in laptops is now sometimes mapped to plain Escape. For "better user experience".

How to fix Esc button not working in Windows 10?

If this really is the case, it might make sense to stop using Shift-Escape as a shortcut altogether. (But need to confirm first.)

Mike Pelletier


1,859 post(s)
#06-Apr-21 16:03

Was troubleshooting yesterday with that same article. FWIW, I have to push the Windows key first before Shift +Esc to make it work. Holding down Shift + Esc, then hitting Windows key doesn't work.

tjhb

9,627 post(s)
#06-Apr-21 17:59

Two left-field possibilities.

(a) You have a keylogger virus/trojan infecting both computers.

(b) You have TeamViewer installed.

tjhb

9,627 post(s)
#06-Apr-21 20:09

(c) Or Citrix.

These are all just hunches.

tjhb

9,627 post(s)
#06-Apr-21 21:59

Or--you haven't said what keyboard you have, only that the brand is Logitech--the driver that Windows (Update) installs by default is intercepting interrupts in case it needs to remap keystrokes.

It would be good to see a screenshot of the Driver tab for the specific keyboard under Device Manager.

Mike Pelletier


1,859 post(s)
#06-Apr-21 23:57

It's a Logitech Deluxe 250. Driver screenshot attached and Windows says it is up-to-date. Don't have those programs installed and doubtful about the virus (good IT dept.). Thanks for the interest Tim.

I do use Chrome and that program also uses Shift Esc. I'll do some tests regarding that.

Attachments:
Capture.JPG

tjhb

9,627 post(s)
#07-Apr-21 00:31

Great, that really is a default driver. So we can discount the keyboard entirely I think.

Chrome seems a good bet. Nasty stuff.

Dimitri


6,511 post(s)
online
#07-Apr-21 13:56

So we can discount the keyboard entirely I think.

No, since a lot depends on what the keyboard is doing internally. Keyboards all now depend on internal programs that run the microcontroller deciding what key presses do, so what the keyboard decides to do when a Shift key and Esc key are pressed together is up to that in-keyboard programming.

A further issue is that the in-keyboard programming might not be interacting with the driver correctly in all cases. That's especially true of keyboards that come with so-called "value added" features.

I got curious about this and did some searches, and there's no end of hits for problems with the Esc key and Shift-Esc sequences with various HP laptops, and Logitech keyboards, as well as with other brands.

As a practical matter, since Microsoft calls the shots on what happens with Windows, the test is to see what Microsoft keyboards and mice do. If you take a clean, freshly loaded Windows system and run your application with a Microsoft keyboard and mouse, if it works fine that's a useful indication it is interacting with Windows correctly.

It's also an indicator that a keyboard is the problem if it works fine, stops working, and then re-installing the driver makes it work again.

I personally don't like Shift-Esc because I'm a touch-typist and that's an awkward combination. I'd prefer Manifold just used Esc. But in any event, the hardware in use shouldn't monkey around with doing anything but providing an honest, unmodified Esc and Shift-Esc if that's what the user presses.

Mike Pelletier


1,859 post(s)
#07-Apr-21 16:05

Perhaps found the problem. Rebooted and Shift Esc works. Fired up Chrome, still works. Restart Mfd with Chrome running, still works. Start Microsoft Teams and now Shift Esc stops working. End Teams, restart Mfd and still doesn't work. Seems like you were barking up the right tree :-)

Agree with Dimitri, that Esc would be preferred over Shift Esc, unless there is some good reason to keep it.

tjhb

9,627 post(s)
#07-Apr-21 21:10

Nice detective work Mike!

Dimitri was right of course, I was too hasty about the keyboard.

But it sounds as if you've nailed it.

Manifold User Community Use Agreement Copyright (C) 2007-2019 Manifold Software Limited. All rights reserved.